summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-05-06 10:20:43 +0000
committerSteven Barth <cyrus@openwrt.org>2013-05-06 10:20:43 +0000
commit9c1ed6447b742a495463f059132073aae1b209c4 (patch)
tree6e86f6c19e9c08f301b609f7798cc0afe2f12361
parent95e139d0b269f86e575b36ebca4ac7d810398246 (diff)
downloadmaster-31e0f0ae-9c1ed6447b742a495463f059132073aae1b209c4.tar.gz
master-31e0f0ae-9c1ed6447b742a495463f059132073aae1b209c4.tar.bz2
master-31e0f0ae-9c1ed6447b742a495463f059132073aae1b209c4.zip
odhcp6c: Make SLAAC-only work without reqprefix=no
Previously if the upstream router did not provide any DHCPv6-service the wan6 interface would not come up even if RAs were received. The new behavior allows the wan6 interface to comeup with RA-only configuration after a timeout of 10s. SVN-Revision: 36555
-rw-r--r--package/network/ipv6/odhcp6c/Makefile4
-rwxr-xr-xpackage/network/ipv6/odhcp6c/files/dhcpv6.script6
2 files changed, 7 insertions, 3 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 298af3d7b9..140f27a313 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-04-23
+PKG_VERSION:=2013-05-05
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=2515dbce13746bb1633cfa4b8e22424946a7f007
+PKG_SOURCE_VERSION:=493b90de720d198a988460bee83340dafbbfa10d
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.script b/package/network/ipv6/odhcp6c/files/dhcpv6.script
index 56f8c39ca4..c81ffee65d 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.script
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.script
@@ -78,7 +78,11 @@ teardown_interface() {
}
case "$2" in
- informed|bound|updated|rebound|ra-updated)
+ bound)
+ teardown_interface "$1"
+ setup_interface "$1"
+ ;;
+ informed|updated|rebound|ra-updated)
setup_interface "$1"
;;
started|stopped|unbound)