summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-02-10 22:36:59 +0000
committerLuka Perkov <luka@openwrt.org>2015-02-10 22:36:59 +0000
commit92f324d33355e26bb119e731197445cf229afbfa (patch)
tree8e167dcfe6a61e3139453af2aae79057c04a6d5b
parent7aa5766ad137c10cca1a67672f2d8371141f7841 (diff)
downloadmaster-31e0f0ae-92f324d33355e26bb119e731197445cf229afbfa.tar.gz
master-31e0f0ae-92f324d33355e26bb119e731197445cf229afbfa.tar.bz2
master-31e0f0ae-92f324d33355e26bb119e731197445cf229afbfa.zip
kernel: switch 3.19 from -rc5 to release .0
Signed-off-by: Luka Perkov <luka@openwrt.org> Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 44381
-rw-r--r--include/kernel-version.mk3
-rw-r--r--target/linux/generic/config-3.192
-rw-r--r--target/linux/generic/patches-3.19/130-mips_cpu_irq_disable.patch20
-rw-r--r--target/linux/generic/patches-3.19/204-module_strip.patch4
-rw-r--r--target/linux/generic/patches-3.19/304-mips_disable_fpu.patch36
-rw-r--r--target/linux/generic/patches-3.19/653-disable_netlink_trim.patch2
-rw-r--r--target/linux/generic/patches-3.19/662-use_fq_codel_by_default.patch2
-rw-r--r--target/linux/generic/patches-3.19/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch18
-rw-r--r--target/linux/generic/patches-3.19/721-phy_packets.patch2
-rw-r--r--target/linux/generic/patches-3.19/771-bgmac-register-napi-before-the-device.patch43
-rw-r--r--target/linux/generic/patches-3.19/772-bgmac-activate-irqs-only-if-there-is-nothing-to-poll.patch29
-rw-r--r--target/linux/generic/patches-3.19/810-pci_disable_common_quirks.patch6
-rw-r--r--target/linux/generic/patches-3.19/834-ledtrig-libata.patch10
-rw-r--r--target/linux/generic/patches-3.19/863-gpiommc.patch2
-rw-r--r--target/linux/generic/patches-3.19/880-gateworks_system_controller.patch2
15 files changed, 33 insertions, 148 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index cc07d3d05d..ec045021b9 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -7,13 +7,14 @@ LINUX_VERSION-3.10 = .58
LINUX_VERSION-3.13 = .7
LINUX_VERSION-3.14 = .32
LINUX_VERSION-3.18 = .6
-LINUX_VERSION-3.19 = -rc5
+LINUX_VERSION-3.19 =
LINUX_KERNEL_MD5SUM-3.8.13 = 2af19d06cd47ec459519159cdd10542d
LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
LINUX_KERNEL_MD5SUM-3.13.7 = 370adced5e5c1cb1d0d621c2dae2723f
LINUX_KERNEL_MD5SUM-3.14.32 = 3178fb8f6f1eafcffdd730fec68754f8
LINUX_KERNEL_MD5SUM-3.18.6 = 997c8492ebfdc9bb9e6ed8d4945539dd
+LINUX_KERNEL_MD5SUM-3.19 = d3fc8316d4d4d04b65cbc2d70799e763
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/generic/config-3.19 b/target/linux/generic/config-3.19
index 0f3fe4ac72..b3064890c9 100644
--- a/target/linux/generic/config-3.19
+++ b/target/linux/generic/config-3.19
@@ -1889,6 +1889,7 @@ CONFIG_LZMA_DECOMPRESS=y
# CONFIG_MAC80211 is not set
# CONFIG_MAC80211_MESSAGE_TRACING is not set
# CONFIG_MACB is not set
+# CONFIG_MACH_ASM9260 is not set
# CONFIG_MACH_DECSTATION is not set
# CONFIG_MACH_JAZZ is not set
# CONFIG_MACH_JZ4740 is not set
@@ -2084,6 +2085,7 @@ CONFIG_MMC_BLOCK_MINORS=8
# CONFIG_MMC_SDRICOH_CS is not set
# CONFIG_MMC_SPI is not set
# CONFIG_MMC_TEST is not set
+# CONFIG_MMC_TOSHIBA_PCI is not set
# CONFIG_MMC_UNSAFE_RESUME is not set
# CONFIG_MMC_USDHI6ROL0 is not set
# CONFIG_MMC_USHC is not set
diff --git a/target/linux/generic/patches-3.19/130-mips_cpu_irq_disable.patch b/target/linux/generic/patches-3.19/130-mips_cpu_irq_disable.patch
deleted file mode 100644
index 659a8d38b4..0000000000
--- a/target/linux/generic/patches-3.19/130-mips_cpu_irq_disable.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/arch/mips/kernel/irq_cpu.c
-+++ b/arch/mips/kernel/irq_cpu.c
-@@ -57,6 +57,8 @@ static struct irq_chip mips_cpu_irq_cont
- .irq_mask_ack = mask_mips_irq,
- .irq_unmask = unmask_mips_irq,
- .irq_eoi = unmask_mips_irq,
-+ .irq_disable = mask_mips_irq,
-+ .irq_enable = unmask_mips_irq,
- };
-
- /*
-@@ -93,6 +95,8 @@ static struct irq_chip mips_mt_cpu_irq_c
- .irq_mask_ack = mips_mt_cpu_irq_ack,
- .irq_unmask = unmask_mips_irq,
- .irq_eoi = unmask_mips_irq,
-+ .irq_disable = mask_mips_irq,
-+ .irq_enable = unmask_mips_irq,
- };
-
- asmlinkage void __weak plat_irq_dispatch(void)
diff --git a/target/linux/generic/patches-3.19/204-module_strip.patch b/target/linux/generic/patches-3.19/204-module_strip.patch
index d71a25f712..00880ab72f 100644
--- a/target/linux/generic/patches-3.19/204-module_strip.patch
+++ b/target/linux/generic/patches-3.19/204-module_strip.patch
@@ -109,7 +109,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
config INIT_ALL_POSSIBLE
--- a/kernel/module.c
+++ b/kernel/module.c
-@@ -2641,6 +2641,7 @@ static struct module *setup_load_info(st
+@@ -2655,6 +2655,7 @@ static struct module *setup_load_info(st
static int check_modinfo(struct module *mod, struct load_info *info, int flags)
{
@@ -117,7 +117,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
const char *modmagic = get_modinfo(info, "vermagic");
int err;
-@@ -2666,6 +2667,7 @@ static int check_modinfo(struct module *
+@@ -2680,6 +2681,7 @@ static int check_modinfo(struct module *
pr_warn("%s: module is from the staging directory, the quality "
"is unknown, you have been warned.\n", mod->name);
}
diff --git a/target/linux/generic/patches-3.19/304-mips_disable_fpu.patch b/target/linux/generic/patches-3.19/304-mips_disable_fpu.patch
index 9cb4f6afa6..8413dba7c2 100644
--- a/target/linux/generic/patches-3.19/304-mips_disable_fpu.patch
+++ b/target/linux/generic/patches-3.19/304-mips_disable_fpu.patch
@@ -1,29 +1,3 @@
-From: Manuel Lauss <manuel.lauss@gmail.com>
-Subject: [RFC PATCH v4 2/2] MIPS: make FPU emulator optional
-Date: Mon, 7 Apr 2014 12:57:04 +0200
-Message-Id: <1396868224-252888-2-git-send-email-manuel.lauss@gmail.com>
-
-This small patch makes the MIPS FPU emulator optional. The kernel
-kills float-users on systems without a hardware FPU by sending a SIGILL.
-
-Disabling the emulator shrinks vmlinux by about 54kBytes (32bit,
-optimizing for size).
-
-Signed-off-by: Manuel Lauss <manuel.lauss@gmail.com>
----
-v4: rediffed because of patch 1/2, should now work with micromips as well
-v3: updated patch description with size savings.
-v2: incorporated changes suggested by Jonas Gorski
- force the fpu emulator on for micromips: relocating the parts
- of the mmips code in the emulator to other areas would be a
- much larger change; I went the cheap route instead with this.
-
- arch/mips/Kbuild | 2 +-
- arch/mips/Kconfig | 14 ++++++++++++++
- arch/mips/include/asm/fpu.h | 5 +++--
- arch/mips/include/asm/fpu_emulator.h | 15 +++++++++++++++
- 4 files changed, 33 insertions(+), 3 deletions(-)
-
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -2521,6 +2521,20 @@ config MIPS_O32_FP64_SUPPORT
@@ -60,12 +34,12 @@ v2: incorporated changes suggested by Jonas Gorski
core-y += arch/mips/
--- a/arch/mips/include/asm/fpu.h
+++ b/arch/mips/include/asm/fpu.h
-@@ -201,8 +201,10 @@ static inline int init_fpu(void)
- write_c0_config5(config5);
- enable_fpu_hazard();
- }
+@@ -210,8 +210,10 @@ static inline int init_fpu(void)
+ /* Restore FRE */
+ write_c0_config5(config5);
+ enable_fpu_hazard();
- } else
-+ } else if (IS_ENABLED(CONFIG_MIPS_FPU_EMULATOR))
++ } else (IS_ENABLED(CONFIG_MIPS_FPU_EMULATOR))
fpu_emulator_init_fpu();
+ else
+ ret = SIGILL;
diff --git a/target/linux/generic/patches-3.19/653-disable_netlink_trim.patch b/target/linux/generic/patches-3.19/653-disable_netlink_trim.patch
index ca5833695b..68b8d5834d 100644
--- a/target/linux/generic/patches-3.19/653-disable_netlink_trim.patch
+++ b/target/linux/generic/patches-3.19/653-disable_netlink_trim.patch
@@ -1,6 +1,6 @@
--- a/net/netlink/af_netlink.c
+++ b/net/netlink/af_netlink.c
-@@ -1702,27 +1702,7 @@ void netlink_detachskb(struct sock *sk,
+@@ -1712,27 +1712,7 @@ void netlink_detachskb(struct sock *sk,
static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
{
diff --git a/target/linux/generic/patches-3.19/662-use_fq_codel_by_default.patch b/target/linux/generic/patches-3.19/662-use_fq_codel_by_default.patch
index 3cbbae3114..e7b781be9b 100644
--- a/target/linux/generic/patches-3.19/662-use_fq_codel_by_default.patch
+++ b/target/linux/generic/patches-3.19/662-use_fq_codel_by_default.patch
@@ -32,7 +32,7 @@
{
--- a/include/net/sch_generic.h
+++ b/include/net/sch_generic.h
-@@ -343,6 +343,7 @@ extern struct Qdisc noop_qdisc;
+@@ -340,6 +340,7 @@ extern struct Qdisc noop_qdisc;
extern struct Qdisc_ops noop_qdisc_ops;
extern struct Qdisc_ops pfifo_fast_ops;
extern struct Qdisc_ops mq_qdisc_ops;
diff --git a/target/linux/generic/patches-3.19/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch b/target/linux/generic/patches-3.19/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
index 157e409739..f32458df30 100644
--- a/target/linux/generic/patches-3.19/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
+++ b/target/linux/generic/patches-3.19/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
@@ -143,7 +143,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
static const struct rt6_info ip6_blk_hole_entry_template = {
.dst = {
.__refcnt = ATOMIC_INIT(1),
-@@ -1593,6 +1610,11 @@ int ip6_route_add(struct fib6_config *cf
+@@ -1594,6 +1611,11 @@ int ip6_route_add(struct fib6_config *cf
rt->dst.output = ip6_pkt_prohibit_out;
rt->dst.input = ip6_pkt_prohibit;
break;
@@ -155,7 +155,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
case RTN_THROW:
default:
rt->dst.error = (cfg->fc_type == RTN_THROW) ? -EAGAIN
-@@ -2154,6 +2176,17 @@ static int ip6_pkt_prohibit_out(struct s
+@@ -2155,6 +2177,17 @@ static int ip6_pkt_prohibit_out(struct s
return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
}
@@ -173,7 +173,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
/*
* Allocate a dst for local (unicast / anycast) address.
*/
-@@ -2377,7 +2410,8 @@ static int rtm_to_fib6_config(struct sk_
+@@ -2378,7 +2411,8 @@ static int rtm_to_fib6_config(struct sk_
if (rtm->rtm_type == RTN_UNREACHABLE ||
rtm->rtm_type == RTN_BLACKHOLE ||
rtm->rtm_type == RTN_PROHIBIT ||
@@ -183,7 +183,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
cfg->fc_flags |= RTF_REJECT;
if (rtm->rtm_type == RTN_LOCAL)
-@@ -2579,6 +2613,9 @@ static int rt6_fill_node(struct net *net
+@@ -2580,6 +2614,9 @@ static int rt6_fill_node(struct net *net
case -EACCES:
rtm->rtm_type = RTN_PROHIBIT;
break;
@@ -193,7 +193,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
case -EAGAIN:
rtm->rtm_type = RTN_THROW;
break;
-@@ -2832,6 +2869,8 @@ static int ip6_route_dev_notify(struct n
+@@ -2833,6 +2870,8 @@ static int ip6_route_dev_notify(struct n
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
net->ipv6.ip6_prohibit_entry->dst.dev = dev;
net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
@@ -202,7 +202,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
#endif
-@@ -3048,6 +3087,17 @@ static int __net_init ip6_route_net_init
+@@ -3049,6 +3088,17 @@ static int __net_init ip6_route_net_init
net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
ip6_template_metrics, true);
@@ -220,7 +220,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
#endif
net->ipv6.sysctl.flush_delay = 0;
-@@ -3066,6 +3116,8 @@ out:
+@@ -3067,6 +3117,8 @@ out:
return ret;
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -229,7 +229,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
out_ip6_prohibit_entry:
kfree(net->ipv6.ip6_prohibit_entry);
out_ip6_null_entry:
-@@ -3083,6 +3135,7 @@ static void __net_exit ip6_route_net_exi
+@@ -3084,6 +3136,7 @@ static void __net_exit ip6_route_net_exi
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
kfree(net->ipv6.ip6_prohibit_entry);
kfree(net->ipv6.ip6_blk_hole_entry);
@@ -237,7 +237,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
#endif
dst_entries_destroy(&net->ipv6.ip6_dst_ops);
}
-@@ -3179,6 +3232,9 @@ int __init ip6_route_init(void)
+@@ -3180,6 +3233,9 @@ int __init ip6_route_init(void)
init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
diff --git a/target/linux/generic/patches-3.19/721-phy_packets.patch b/target/linux/generic/patches-3.19/721-phy_packets.patch
index 6c0898c5ee..68ba8fc306 100644
--- a/target/linux/generic/patches-3.19/721-phy_packets.patch
+++ b/target/linux/generic/patches-3.19/721-phy_packets.patch
@@ -86,7 +86,7 @@
help
--- a/net/core/dev.c
+++ b/net/core/dev.c
-@@ -2620,10 +2620,20 @@ static int xmit_one(struct sk_buff *skb,
+@@ -2591,10 +2591,20 @@ static int xmit_one(struct sk_buff *skb,
if (!list_empty(&ptype_all))
dev_queue_xmit_nit(skb, dev);
diff --git a/target/linux/generic/patches-3.19/771-bgmac-register-napi-before-the-device.patch b/target/linux/generic/patches-3.19/771-bgmac-register-napi-before-the-device.patch
deleted file mode 100644
index 56248c6720..0000000000
--- a/target/linux/generic/patches-3.19/771-bgmac-register-napi-before-the-device.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From d5b4e70e8c205a67e2e246908b259367ab9ccecf Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Mon, 8 Dec 2014 08:27:23 +0100
-Subject: [PATCH 2/4] bgmac: register napi before the device
-
-napi should get registered before the netdev and not after.
-
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
----
- drivers/net/ethernet/broadcom/bgmac.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
---- a/drivers/net/ethernet/broadcom/bgmac.c
-+++ b/drivers/net/ethernet/broadcom/bgmac.c
-@@ -1515,6 +1515,8 @@ static int bgmac_probe(struct bcma_devic
- if (core->bus->sprom.boardflags_lo & BGMAC_BFL_ENETADM)
- bgmac_warn(bgmac, "Support for ADMtek ethernet switch not implemented\n");
-
-+ netif_napi_add(net_dev, &bgmac->napi, bgmac_poll, BGMAC_WEIGHT);
-+
- err = bgmac_mii_register(bgmac);
- if (err) {
- bgmac_err(bgmac, "Cannot register MDIO\n");
-@@ -1529,8 +1531,6 @@ static int bgmac_probe(struct bcma_devic
-
- netif_carrier_off(net_dev);
-
-- netif_napi_add(net_dev, &bgmac->napi, bgmac_poll, BGMAC_WEIGHT);
--
- return 0;
-
- err_mii_unregister:
-@@ -1549,9 +1549,9 @@ static void bgmac_remove(struct bcma_dev
- {
- struct bgmac *bgmac = bcma_get_drvdata(core);
-
-- netif_napi_del(&bgmac->napi);
- unregister_netdev(bgmac->net_dev);
- bgmac_mii_unregister(bgmac);
-+ netif_napi_del(&bgmac->napi);
- bgmac_dma_free(bgmac);
- bcma_set_drvdata(core, NULL);
- free_netdev(bgmac->net_dev);
diff --git a/target/linux/generic/patches-3.19/772-bgmac-activate-irqs-only-if-there-is-nothing-to-poll.patch b/target/linux/generic/patches-3.19/772-bgmac-activate-irqs-only-if-there-is-nothing-to-poll.patch
deleted file mode 100644
index b494998be3..0000000000
--- a/target/linux/generic/patches-3.19/772-bgmac-activate-irqs-only-if-there-is-nothing-to-poll.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From fbd3b188fbaa861165a074c454d8f8dcf15343a0 Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Mon, 8 Dec 2014 08:47:10 +0100
-Subject: [PATCH 3/4] bgmac: activate irqs only if there is nothing to poll
-
-IRQs should only get activated when there is nothing to poll in the
-queue any more and to after every poll.
-
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
----
- drivers/net/ethernet/broadcom/bgmac.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
---- a/drivers/net/ethernet/broadcom/bgmac.c
-+++ b/drivers/net/ethernet/broadcom/bgmac.c
-@@ -1167,10 +1167,10 @@ static int bgmac_poll(struct napi_struct
- bgmac->int_status = 0;
- }
-
-- if (handled < weight)
-+ if (handled < weight) {
- napi_complete(napi);
--
-- bgmac_chip_intrs_on(bgmac);
-+ bgmac_chip_intrs_on(bgmac);
-+ }
-
- return handled;
- }
diff --git a/target/linux/generic/patches-3.19/810-pci_disable_common_quirks.patch b/target/linux/generic/patches-3.19/810-pci_disable_common_quirks.patch
index 526a891f48..eee15517e0 100644
--- a/target/linux/generic/patches-3.19/810-pci_disable_common_quirks.patch
+++ b/target/linux/generic/patches-3.19/810-pci_disable_common_quirks.patch
@@ -23,7 +23,7 @@
/* The Mellanox Tavor device gives false positive parity errors
* Mark this device with a broken_parity_status, to allow
* PCI scanning code to "skip" this now blacklisted device.
-@@ -2891,6 +2892,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
+@@ -2925,6 +2926,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65f9, quirk_intel_mc_errata);
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65fa, quirk_intel_mc_errata);
@@ -31,7 +31,7 @@
/*
* Ivytown NTB BAR sizes are misreported by the hardware due to an erratum. To
-@@ -2947,6 +2949,8 @@ static void fixup_debug_report(struct pc
+@@ -2981,6 +2983,8 @@ static void fixup_debug_report(struct pc
}
}
@@ -40,7 +40,7 @@
/*
* Some BIOS implementations leave the Intel GPU interrupts enabled,
* even though no one is handling them (f.e. i915 driver is never loaded).
-@@ -2981,6 +2985,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
+@@ -3015,6 +3019,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x010a, disable_igfx_irq);
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0152, disable_igfx_irq);
diff --git a/target/linux/generic/patches-3.19/834-ledtrig-libata.patch b/target/linux/generic/patches-3.19/834-ledtrig-libata.patch
index b7ba002453..0512f540e0 100644
--- a/target/linux/generic/patches-3.19/834-ledtrig-libata.patch
+++ b/target/linux/generic/patches-3.19/834-ledtrig-libata.patch
@@ -69,7 +69,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
/**
* ata_build_rw_tf - Build ATA taskfile for given read/write request
* @tf: Target ATA taskfile
-@@ -4761,6 +4774,9 @@ static struct ata_queued_cmd *ata_qc_new
+@@ -4787,6 +4800,9 @@ static struct ata_queued_cmd *ata_qc_new
break;
}
}
@@ -79,7 +79,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
return qc;
}
-@@ -5671,6 +5687,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5697,6 +5713,9 @@ struct ata_port *ata_port_alloc(struct a
ap->stats.unhandled_irq = 1;
ap->stats.idle_irq = 1;
#endif
@@ -89,7 +89,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
ata_sff_port_init(ap);
return ap;
-@@ -5692,6 +5711,12 @@ static void ata_host_release(struct devi
+@@ -5718,6 +5737,12 @@ static void ata_host_release(struct devi
kfree(ap->pmp_link);
kfree(ap->slave_link);
@@ -102,7 +102,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
kfree(ap);
host->ports[i] = NULL;
}
-@@ -6138,7 +6163,23 @@ int ata_host_register(struct ata_host *h
+@@ -6164,7 +6189,23 @@ int ata_host_register(struct ata_host *h
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
host->ports[i]->local_port_no = i + 1;
}
@@ -138,7 +138,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
/*
* Define if arch has non-standard setup. This is a _PCI_ standard
-@@ -862,6 +865,12 @@ struct ata_port {
+@@ -864,6 +867,12 @@ struct ata_port {
#ifdef CONFIG_ATA_ACPI
struct ata_acpi_gtm __acpi_init_gtm; /* use ata_acpi_init_gtm() */
#endif
diff --git a/target/linux/generic/patches-3.19/863-gpiommc.patch b/target/linux/generic/patches-3.19/863-gpiommc.patch
index 8dcb1742fc..ff8baf788c 100644
--- a/target/linux/generic/patches-3.19/863-gpiommc.patch
+++ b/target/linux/generic/patches-3.19/863-gpiommc.patch
@@ -830,7 +830,7 @@
+be done automatically.
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -4388,6 +4388,11 @@ T: git git://linuxtv.org/anttip/media_tr
+@@ -4393,6 +4393,11 @@ T: git git://linuxtv.org/anttip/media_tr
S: Maintained
F: drivers/media/usb/hackrf/
diff --git a/target/linux/generic/patches-3.19/880-gateworks_system_controller.patch b/target/linux/generic/patches-3.19/880-gateworks_system_controller.patch
index 07fd131071..32796d5b5a 100644
--- a/target/linux/generic/patches-3.19/880-gateworks_system_controller.patch
+++ b/target/linux/generic/patches-3.19/880-gateworks_system_controller.patch
@@ -18,7 +18,7 @@
depends on GPIOLIB
--- a/drivers/hwmon/Makefile
+++ b/drivers/hwmon/Makefile
-@@ -154,6 +154,7 @@ obj-$(CONFIG_SENSORS_W83L785TS) += w83l7
+@@ -155,6 +155,7 @@ obj-$(CONFIG_SENSORS_W83L785TS) += w83l7
obj-$(CONFIG_SENSORS_W83L786NG) += w83l786ng.o
obj-$(CONFIG_SENSORS_WM831X) += wm831x-hwmon.o
obj-$(CONFIG_SENSORS_WM8350) += wm8350-hwmon.o