summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-02 17:24:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-02 17:24:20 +0000
commit91e5dba2c76d9185cc06c32feb51b8b0d1c310ca (patch)
tree33c544be12c7aaaaff28f785b5ae40263645fe9a
parent983544f859e946494b3029a41bb7880b93c46037 (diff)
downloadmaster-31e0f0ae-91e5dba2c76d9185cc06c32feb51b8b0d1c310ca.tar.gz
master-31e0f0ae-91e5dba2c76d9185cc06c32feb51b8b0d1c310ca.tar.bz2
master-31e0f0ae-91e5dba2c76d9185cc06c32feb51b8b0d1c310ca.zip
kernel build cleanup
SVN-Revision: 6464
-rw-r--r--include/image.mk6
-rw-r--r--include/kernel-build.mk1
-rw-r--r--target/linux/atheros-2.6/image/Makefile4
-rw-r--r--target/linux/rb532-2.6/image/Makefile1
4 files changed, 5 insertions, 7 deletions
diff --git a/include/image.mk b/include/image.mk
index 9c170af11b..78e1a2fdc8 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -61,8 +61,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
endef
endif
-
-
+else
+ define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+ endef
endif
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 6aec7c7270..3a17182a27 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -136,6 +136,7 @@ define Kernel/CompileImage/Default
$(call Kernel/SetInitramfs)
$(MAKE) -j$(CONFIG_JLEVEL) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" $(KERNELNAME)
$(KERNEL_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
+ $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.elf
endef
define Kernel/CompileImage
$(call Kernel/CompileImage/Default)
diff --git a/target/linux/atheros-2.6/image/Makefile b/target/linux/atheros-2.6/image/Makefile
index dfd1746fd3..1d32a4bd46 100644
--- a/target/linux/atheros-2.6/image/Makefile
+++ b/target/linux/atheros-2.6/image/Makefile
@@ -7,10 +7,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Image/Prepare
- cp $(KDIR)/linux-*/vmlinux $(KDIR)/vmlinux.elf
-endef
-
define Image/BuildKernel
cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index b35b0b1e7b..e6794c036d 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -31,7 +31,6 @@ endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
- $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.elf
endef
define Image/BuildKernel