summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-06-06 04:43:55 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-06-06 04:43:55 +0000
commit91aa0a7ca07219c2fef2686789813d98ad53b2f2 (patch)
treea0cf2544ea48d2757105bc0567911ece24f90cd9
parent4c9e3682cb405d850902b7d1c54e2c8a74cbb10c (diff)
downloadmaster-31e0f0ae-91aa0a7ca07219c2fef2686789813d98ad53b2f2.tar.gz
master-31e0f0ae-91aa0a7ca07219c2fef2686789813d98ad53b2f2.tar.bz2
master-31e0f0ae-91aa0a7ca07219c2fef2686789813d98ad53b2f2.zip
make the AP83 and VSC7385 SPI drivers available on 2.6.2[89]
SVN-Revision: 16351
-rw-r--r--target/linux/ar71xx/config-2.6.282
-rw-r--r--target/linux/ar71xx/config-2.6.292
-rw-r--r--target/linux/ar71xx/patches-2.6.28/201-ap83_spi_controller.patch27
-rw-r--r--target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch24
-rw-r--r--target/linux/ar71xx/patches-2.6.29/201-ap83_spi_controller.patch27
-rw-r--r--target/linux/ar71xx/patches-2.6.29/202-spi_vsc7385_driver.patch24
6 files changed, 106 insertions, 0 deletions
diff --git a/target/linux/ar71xx/config-2.6.28 b/target/linux/ar71xx/config-2.6.28
index 2fcd9ccddb..6148e60d26 100644
--- a/target/linux/ar71xx/config-2.6.28
+++ b/target/linux/ar71xx/config-2.6.28
@@ -177,11 +177,13 @@ CONFIG_SERIAL_8250_RUNTIME_UARTS=1
# CONFIG_SLAB is not set
CONFIG_SLUB=y
CONFIG_SPI=y
+CONFIG_SPI_AP83=y
CONFIG_SPI_AR71XX=y
CONFIG_SPI_BITBANG=y
CONFIG_SPI_GPIO=y
CONFIG_SPI_MASTER=y
# CONFIG_SPI_SPIDEV is not set
+# CONFIG_SPI_VSC7385 is not set
CONFIG_SYS_HAS_CPU_MIPS32_R1=y
CONFIG_SYS_HAS_CPU_MIPS32_R2=y
CONFIG_SYS_HAS_EARLY_PRINTK=y
diff --git a/target/linux/ar71xx/config-2.6.29 b/target/linux/ar71xx/config-2.6.29
index 7acfbb826c..59265aa69b 100644
--- a/target/linux/ar71xx/config-2.6.29
+++ b/target/linux/ar71xx/config-2.6.29
@@ -182,11 +182,13 @@ CONFIG_SERIAL_8250_RUNTIME_UARTS=1
# CONFIG_SLAB is not set
CONFIG_SLUB=y
CONFIG_SPI=y
+CONFIG_SPI_AP83=y
CONFIG_SPI_AR71XX=y
CONFIG_SPI_BITBANG=y
CONFIG_SPI_GPIO=y
CONFIG_SPI_MASTER=y
# CONFIG_SPI_SPIDEV is not set
+# CONFIG_SPI_VSC7385 is not set
CONFIG_SYS_HAS_CPU_MIPS32_R1=y
CONFIG_SYS_HAS_CPU_MIPS32_R2=y
CONFIG_SYS_HAS_EARLY_PRINTK=y
diff --git a/target/linux/ar71xx/patches-2.6.28/201-ap83_spi_controller.patch b/target/linux/ar71xx/patches-2.6.28/201-ap83_spi_controller.patch
new file mode 100644
index 0000000000..a8e889a7bd
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.28/201-ap83_spi_controller.patch
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -11,6 +11,7 @@ endif
+ obj-$(CONFIG_SPI_MASTER) += spi.o
+
+ # SPI master controller drivers (bus)
++obj-$(CONFIG_SPI_AP83) += ap83_spi.o
+ obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
+ obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
+ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.o
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -53,6 +53,14 @@ if SPI_MASTER
+
+ comment "SPI Master Controller Drivers"
+
++config SPI_AP83
++ tristate "Atheros AP83 specific SPI Controller"
++ depends on SPI_MASTER && AR71XX_MACH_AP83
++ select SPI_BITBANG
++ help
++ This is a specific SPI controller driver for the Atheros AP83
++ reference board.
++
+ config SPI_AR71XX
+ tristate "Atheros AR71xx SPI Controller"
+ depends on SPI_MASTER && ATHEROS_AR71XX
diff --git a/target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..26f6156dab
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.28/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -283,6 +283,11 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -38,6 +38,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_AT25) += at25.o
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+
diff --git a/target/linux/ar71xx/patches-2.6.29/201-ap83_spi_controller.patch b/target/linux/ar71xx/patches-2.6.29/201-ap83_spi_controller.patch
new file mode 100644
index 0000000000..a8e889a7bd
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/201-ap83_spi_controller.patch
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -11,6 +11,7 @@ endif
+ obj-$(CONFIG_SPI_MASTER) += spi.o
+
+ # SPI master controller drivers (bus)
++obj-$(CONFIG_SPI_AP83) += ap83_spi.o
+ obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
+ obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
+ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.o
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -53,6 +53,14 @@ if SPI_MASTER
+
+ comment "SPI Master Controller Drivers"
+
++config SPI_AP83
++ tristate "Atheros AP83 specific SPI Controller"
++ depends on SPI_MASTER && AR71XX_MACH_AP83
++ select SPI_BITBANG
++ help
++ This is a specific SPI controller driver for the Atheros AP83
++ reference board.
++
+ config SPI_AR71XX
+ tristate "Atheros AR71xx SPI Controller"
+ depends on SPI_MASTER && ATHEROS_AR71XX
diff --git a/target/linux/ar71xx/patches-2.6.29/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.29/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..b071d5d21c
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -272,6 +272,11 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
+
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+