summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-12-19 19:17:53 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-12-19 19:17:53 +0000
commit91491c6e37b69cc26acd82f3685e71720c415831 (patch)
tree8efab74a5183590523510ce0e04db3d5a0d1729a
parent85d59fbf8c0c41ba4bcc5e426461ed005c13f97a (diff)
downloadmaster-31e0f0ae-91491c6e37b69cc26acd82f3685e71720c415831.tar.gz
master-31e0f0ae-91491c6e37b69cc26acd82f3685e71720c415831.tar.bz2
master-31e0f0ae-91491c6e37b69cc26acd82f3685e71720c415831.zip
rename RouterStation stuff, and add machine type for the LSX board
SVN-Revision: 13694
-rw-r--r--target/linux/ar71xx/config-2.6.262
-rw-r--r--target/linux/ar71xx/config-2.6.272
-rw-r--r--target/linux/ar71xx/config-2.6.281
-rw-r--r--target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h3
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig4
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/mach-ubnt.c (renamed from target/linux/ar71xx/files/arch/mips/ar71xx/mach-routerstation.c)4
-rw-r--r--target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h3
8 files changed, 12 insertions, 9 deletions
diff --git a/target/linux/ar71xx/config-2.6.26 b/target/linux/ar71xx/config-2.6.26
index f091cdf58a..6fe9333963 100644
--- a/target/linux/ar71xx/config-2.6.26
+++ b/target/linux/ar71xx/config-2.6.26
@@ -8,8 +8,8 @@ CONFIG_AR71XX_MACH_AP83=y
CONFIG_AR71XX_MACH_AW_NR580=y
CONFIG_AR71XX_MACH_GENERIC=y
CONFIG_AR71XX_MACH_RB_4XX=y
-CONFIG_AR71XX_MACH_ROUTERSTATION=y
CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_UBNT=y
CONFIG_AR71XX_MACH_WP543=y
CONFIG_AR71XX_WDT=y
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
diff --git a/target/linux/ar71xx/config-2.6.27 b/target/linux/ar71xx/config-2.6.27
index 566c8cda51..5cb344df2d 100644
--- a/target/linux/ar71xx/config-2.6.27
+++ b/target/linux/ar71xx/config-2.6.27
@@ -8,8 +8,8 @@ CONFIG_AR71XX_MACH_AP83=y
CONFIG_AR71XX_MACH_AW_NR580=y
CONFIG_AR71XX_MACH_GENERIC=y
CONFIG_AR71XX_MACH_RB_4XX=y
-CONFIG_AR71XX_MACH_ROUTERSTATION=y
CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_UBNT=y
CONFIG_AR71XX_MACH_WP543=y
CONFIG_AR71XX_WDT=y
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
diff --git a/target/linux/ar71xx/config-2.6.28 b/target/linux/ar71xx/config-2.6.28
index 077260dd9c..17eafa13d7 100644
--- a/target/linux/ar71xx/config-2.6.28
+++ b/target/linux/ar71xx/config-2.6.28
@@ -9,6 +9,7 @@ CONFIG_AR71XX_MACH_AW_NR580=y
CONFIG_AR71XX_MACH_GENERIC=y
CONFIG_AR71XX_MACH_RB_4XX=y
CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_UBNT=y
CONFIG_AR71XX_MACH_WP543=y
CONFIG_AR71XX_WDT=y
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
diff --git a/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h b/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
index 87af166d5e..8379aedab1 100644
--- a/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
+++ b/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
@@ -114,7 +114,8 @@ extern unsigned long ar71xx_mach_type;
#define AR71XX_MACH_AW_NR580 6 /* AzureWave AW-NR580 */
#define AR71XX_MACH_AP83 7 /* Atheros AP83 */
#define AR71XX_MACH_TEW_632BRP 8 /* TRENDnet TEW-632BRP */
-#define AR71XX_MACH_ROUTERSTATION 9 /* Ubiquiti RouterStation */
+#define AR71XX_MACH_UBNT_RS 9 /* Ubiquiti RouterStation */
+#define AR71XX_MACH_UBNT_LSX 10 /* Ubiquiti LSX */
/*
* PLL block
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
index d16fdb8240..66500a94bd 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
@@ -31,8 +31,8 @@ config AR71XX_MACH_TEW_632BRP
bool "TRENDnet TEW-632BRP support"
default y
-config AR71XX_MACH_ROUTERSTATION
- bool "Ubiquiti RouterStation support"
+config AR71XX_MACH_UBNT
+ bool "Ubiquiti AR71xx based boards support"
default y
endmenu
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
index f53dc9daf1..902cbc353f 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
@@ -14,6 +14,6 @@ obj-$(CONFIG_AR71XX_MACH_AP83) += mach-ap83.o
obj-$(CONFIG_AR71XX_MACH_AW_NR580) += mach-aw-nr580.o
obj-$(CONFIG_AR71XX_MACH_GENERIC) += mach-generic.o
obj-$(CONFIG_AR71XX_MACH_RB_4XX) += mach-rb-4xx.o
-obj-$(CONFIG_AR71XX_MACH_ROUTERSTATION) += mach-routerstation.o
obj-$(CONFIG_AR71XX_MACH_TEW_632BRP) += mach-tew-632brp.o
+obj-$(CONFIG_AR71XX_MACH_UBNT) += mach-ubnt.o
obj-$(CONFIG_AR71XX_MACH_WP543) += mach-wp543.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-routerstation.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ubnt.c
index a8de7117f5..b1b18f9d47 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-routerstation.c
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ubnt.c
@@ -33,5 +33,5 @@ static void __init routerstation_setup(void)
ARRAY_SIZE(routerstation_spi_info));
}
-MIPS_MACHINE(AR71XX_MACH_ROUTERSTATION, "Ubiquiti RouterStation",
- routerstation_setup);
+MIPS_MACHINE(AR71XX_MACH_UBNT_RS, "Ubiquiti RouterStation",
+ routerstation_setup);
diff --git a/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h b/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h
index 87af166d5e..8379aedab1 100644
--- a/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h
+++ b/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h
@@ -114,7 +114,8 @@ extern unsigned long ar71xx_mach_type;
#define AR71XX_MACH_AW_NR580 6 /* AzureWave AW-NR580 */
#define AR71XX_MACH_AP83 7 /* Atheros AP83 */
#define AR71XX_MACH_TEW_632BRP 8 /* TRENDnet TEW-632BRP */
-#define AR71XX_MACH_ROUTERSTATION 9 /* Ubiquiti RouterStation */
+#define AR71XX_MACH_UBNT_RS 9 /* Ubiquiti RouterStation */
+#define AR71XX_MACH_UBNT_LSX 10 /* Ubiquiti LSX */
/*
* PLL block