summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-15 23:46:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-15 23:46:30 +0000
commit8e2643a8b517b0ff5030f05020c48fc7bc0e85c2 (patch)
treed65c649a0e3df1b46ec0167369fb9a421647cc4f
parent6a9fcdcef46a71b6a5a32be98d018e6c1a3690c8 (diff)
downloadmaster-31e0f0ae-8e2643a8b517b0ff5030f05020c48fc7bc0e85c2.tar.gz
master-31e0f0ae-8e2643a8b517b0ff5030f05020c48fc7bc0e85c2.tar.bz2
master-31e0f0ae-8e2643a8b517b0ff5030f05020c48fc7bc0e85c2.zip
add dropbear host keys to conffiles
SVN-Revision: 7642
-rw-r--r--package/dropbear/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index 25a0cd0f55..60625947af 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
PKG_VERSION:=0.49
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
@@ -86,6 +86,9 @@ define Package/dropbear/install
$(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
+ $(INSTALL_DIR) $(1)/usr/lib/ipkg/info
+ echo /etc/dropbear/dropbear_rsa_host_key > $(1)/usr/lib/ipkg/info/dropbear.conffiles
+ echo /etc/dropbear/dropbear_dss_host_key >> $(1)/usr/lib/ipkg/info/dropbear.conffiles
endef
define Package/dropbearconvert/install