summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-17 14:06:13 +0000
committerJohn Crispin <john@openwrt.org>2015-01-17 14:06:13 +0000
commit88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2 (patch)
treea12ec319f40eaf27b5bbf6000bc60429e781f051
parent744298b8a0dc363a802634b5ac5d08e861e65d12 (diff)
downloadmaster-31e0f0ae-88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2.tar.gz
master-31e0f0ae-88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2.tar.bz2
master-31e0f0ae-88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2.zip
ramips: add support for Intenso Memory 2 Move USB 3.0
This adds support for a rt5350-based "portable nas" solution from Intenso. The board comes with 32M RAM and 8M Flash, the built-in HDD is connected/accessible via a usb3.0<->sata bridge VLI VL701. The device has 1 Ethernet port (100M/10M), 1 micro b usb 3.0 socket (for charging the battery, or accessing the hdd directly). Wireless connectivity is provided by the rt5350 SoC [i.e.: 802.11n 1x1 2.4 GHz with a pcb antenna.] Serial, leds, wifi, ethernet and usb are tested and as far as I can tell: they are working fine (tm). Signed-off-by: Christian Lamparter <chunkeey@googlemail.com> SVN-Revision: 44001
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network5
-rwxr-xr-xtarget/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/M2M.dts113
-rw-r--r--target/linux/ramips/image/Makefile3
-rw-r--r--target/linux/ramips/rt305x/profiles/m2m.mk20
8 files changed, 152 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index dfd0ca7049..8695cdeb65 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -152,6 +152,10 @@ case $board in
nw718)
set_usb_led "nw718:amber:usb"
;;
+ m2m)
+ set_wifi_led "m2m:blue:wifi"
+ ucidef_set_led_netdev "eth" "Ethernet" "m2m:green:wan" "eth0"
+ ;;
omni-emb-hpm)
ucidef_set_led_default "power" "POWER" "emb:orange:power" "1"
ucidef_set_led_netdev "eth" "ETH" "emb:green:eth" "eth0"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index aad119738b..70b369de6a 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -65,6 +65,11 @@ ramips_setup_interfaces()
ucidef_set_interface_lan "eth0.1"
;;
+ m2m)
+ ucidef_add_switch "switch0" "4"
+ ucidef_set_interface_lan "eth0"
+ ;;
+
wizard8800 | \
wl-330n | \
wmr300)
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 65ef0db96a..1693e9d4fe 100755
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -79,6 +79,9 @@ get_status_led() {
hw550-3g)
status_led="hw550-3g:green:status"
;;
+ m2m)
+ status_led="m2m:blue:wifi"
+ ;;
m3)
status_led="m3:blue:status"
;;
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 379713bf21..5918640985 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -214,6 +214,9 @@ ramips_board_detect() {
*"NW718")
name="nw718"
;;
+ *"Intenso Memory 2 Move")
+ name="m2m"
+ ;;
*"Omnima EMB HPM")
name="omni-emb-hpm"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index b5eecfc299..2c423443c7 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -55,6 +55,7 @@ platform_check_image() {
ht-tm02 | \
hw550-3g | \
ip2202 | \
+ m2m | \
m3 | \
m4 | \
mlw221 | \
diff --git a/target/linux/ramips/dts/M2M.dts b/target/linux/ramips/dts/M2M.dts
new file mode 100644
index 0000000000..aa98991ae1
--- /dev/null
+++ b/target/linux/ramips/dts/M2M.dts
@@ -0,0 +1,113 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+ compatible = "M2M", "ralink,rt5350-soc";
+ model = "Intenso Memory 2 Move";
+
+ chosen {
+ bootargs = "console=ttyS1,57600n8 root=/dev/mtdblock5";
+ };
+
+ palmbus@10000000 {
+ uart@500 {
+ status = "okay";
+ };
+
+ spi@b00 {
+ status = "okay";
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "mx25l6405d";
+ reg = <0 0>;
+ linux,modalias = "m25p80", "mx25l6405d";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "Bootloader";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "Config";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "Factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "jtag", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ wifi {
+ label = "m2m:blue:wifi";
+ gpios = <&gpio0 7 1>;
+ };
+ wan {
+ label = "m2m:green:wan";
+ gpios = <&gpio0 12 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ power {
+ label = "power";
+ gpios = <&gpio0 1 1>;
+ linux,code = <0x116>;
+ };
+ reset {
+ label = "reset";
+ gpios = <&gpio0 10 1>;
+ linux,code = <0x198>;
+ };
+ };
+ };
+
+ ethernet@10100000 {
+ mtd-mac-address = <&factory 0x28>;
+ };
+
+ esw@10110000 {
+ ralink,portmap = <0x2f>;
+ };
+
+ ehci@101c0000 {
+ status = "okay";
+ };
+
+ ohci@101c1000 {
+ status = "okay";
+ };
+
+ wmac@10180000 {
+ ralink,mtd-eeprom = <&factory 0x0>;
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 21c8a8ddc9..5e4cea35ac 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -546,6 +546,8 @@ Image/Build/Profile/NCS601W=$(call BuildFirmware/Default8M/$(1),$(1),ncs601W,NCS
nw718_mtd_size=3801088
Image/Build/Profile/NW718=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),nw718m,NW718,$(nw718_mtd_size),ARA1B4NCRNW718;1,factory)
+Image/Build/Profile/M2M=$(call BuildFirmware/Default8M/$(1),$(1),m2m,M2M,Linux Kernel Image)
+
Image/Build/Profile/OMNI-EMB=$(call BuildFirmware/Default8M/$(1),$(1),omni-emb,OMNI-EMB)
Image/Build/Profile/OMNI-PLUG=$(call BuildFirmware/Default8M/$(1),$(1),omni-plug,OMNI-PLUG)
@@ -694,6 +696,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/HT-TM02,$(1))
$(call Image/Build/Profile/HW550-3G,$(1))
$(call Image/Build/Profile/IP2202,$(1))
+ $(call Image/Build/Profile/M2M,$(1))
$(call Image/Build/Profile/M3,$(1))
$(call Image/Build/Profile/M4,$(1))
$(call Image/Build/Profile/MOFI3500-3GN,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/m2m.mk b/target/linux/ramips/rt305x/profiles/m2m.mk
new file mode 100644
index 0000000000..ea803baa25
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/m2m.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/M2M
+ NAME:=Intenso Memory 2 Move
+ PACKAGES:=\
+ kmod-ledtrig-netdev kmod-ledtrig-timer kmod-leds-gpio \
+ kmod-usb-core kmod-usb2 kmod-usb-storage kmod-scsi-core \
+ kmod-fs-ext4 kmod-fs-vfat block-mount
+endef
+
+define Profile/M2M/Description
+ Package set for Intenso Memory 2 Move USB 3.0
+endef
+
+$(eval $(call Profile,M2M))