summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-08 21:18:19 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-08 21:18:19 +0000
commit880b837992cb63fbfd62df567658881e238875b4 (patch)
tree02cc3bee5fb65c4cd47b20c5bb638d82ea98063d
parent2b58e316745a264251d638c8f58495c0d4915d7d (diff)
downloadmaster-31e0f0ae-880b837992cb63fbfd62df567658881e238875b4.tar.gz
master-31e0f0ae-880b837992cb63fbfd62df567658881e238875b4.tar.bz2
master-31e0f0ae-880b837992cb63fbfd62df567658881e238875b4.zip
Enable codepage 1250 support (#1554)
SVN-Revision: 6906
-rw-r--r--package/kernel/modules/fs.mk10
-rw-r--r--target/linux/generic-2.6/config-template2
2 files changed, 11 insertions, 1 deletions
diff --git a/package/kernel/modules/fs.mk b/package/kernel/modules/fs.mk
index a003e268ec..2106881ec8 100644
--- a/package/kernel/modules/fs.mk
+++ b/package/kernel/modules/fs.mk
@@ -172,6 +172,16 @@ define KernelPackage/nls-cp850
endef
$(eval $(call KernelPackage,nls-cp850))
+define KernelPackage/nls-cp1250
+ TITLE:=Codepage 1250 (Eastern Europe)
+ DESCRIPTION:=Kernel module for NLS Codepage 1250 (Eastern Europe)
+ DEPENDS:=kmod-nls-base
+ KCONFIG:=$(CONFIG_NLS_CODEPAGE_1250)
+ SUBMENU:=$(FSMENU)
+ FILES:=$(MODULES_DIR)/kernel/fs/nls/nls_cp1250.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,25,nls_cp1250)
+endef
+$(eval $(call KernelPackage,nls-cp1250))
define KernelPackage/nls-iso8859-1
TITLE:=ISO 8859-1 (Latin 1; Western European Languages)
diff --git a/target/linux/generic-2.6/config-template b/target/linux/generic-2.6/config-template
index 7d5f5b5dec..498ba0674b 100644
--- a/target/linux/generic-2.6/config-template
+++ b/target/linux/generic-2.6/config-template
@@ -688,7 +688,7 @@ CONFIG_NFS_V4=y
# CONFIG_NFTL is not set
CONFIG_NLS=m
# CONFIG_NLS_ASCII is not set
-# CONFIG_NLS_CODEPAGE_1250 is not set
+CONFIG_NLS_CODEPAGE_1250=m
# CONFIG_NLS_CODEPAGE_1251 is not set
CONFIG_NLS_CODEPAGE_437=m
# CONFIG_NLS_CODEPAGE_737 is not set