summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-06-30 23:26:13 +0000
committerJonas Gorski <jogo@openwrt.org>2015-06-30 23:26:13 +0000
commit831d1c8b459b561d18446566ff16049d3025967c (patch)
treeb92538ea45c69901bdb5be2e77e28f9f1f653d38
parent901a7fa067c63a81eda14becfffa1bbd79009e33 (diff)
downloadmaster-31e0f0ae-831d1c8b459b561d18446566ff16049d3025967c.tar.gz
master-31e0f0ae-831d1c8b459b561d18446566ff16049d3025967c.tar.bz2
master-31e0f0ae-831d1c8b459b561d18446566ff16049d3025967c.zip
kernel: update 4.0 to 4.0.7
Changelog: * https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.0.6 * https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.0.7 Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46151
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-4.0/180-usb-xhci-make-USB_XHCI_PLATFORM-selectable.patch5
-rw-r--r--target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch2
-rw-r--r--target/linux/generic/patches-4.0/653-disable_netlink_trim.patch2
-rw-r--r--target/linux/generic/patches-4.0/664-codel_fix_3_12.patch2
-rw-r--r--target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch2
6 files changed, 6 insertions, 11 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 8bac82461b..fd1efdbfbd 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,11 +3,11 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .17
-LINUX_VERSION-4.0 = .5
+LINUX_VERSION-4.0 = .7
LINUX_VERSION-4.1 =
LINUX_KERNEL_MD5SUM-3.18.17 = f05d7620c587d8b0ab3cd944ff9dc9f7
-LINUX_KERNEL_MD5SUM-4.0.5 = 214836ae60a5674c31bb7cede5f47794
+LINUX_KERNEL_MD5SUM-4.0.7 = 7993e5389c189d5c7dbc21135aebc0c1
LINUX_KERNEL_MD5SUM-4.1 = fe9dc0f6729f36400ea81aa41d614c37
ifdef KERNEL_PATCHVER
diff --git a/target/linux/generic/patches-4.0/180-usb-xhci-make-USB_XHCI_PLATFORM-selectable.patch b/target/linux/generic/patches-4.0/180-usb-xhci-make-USB_XHCI_PLATFORM-selectable.patch
index e86ab3f565..a17e39800c 100644
--- a/target/linux/generic/patches-4.0/180-usb-xhci-make-USB_XHCI_PLATFORM-selectable.patch
+++ b/target/linux/generic/patches-4.0/180-usb-xhci-make-USB_XHCI_PLATFORM-selectable.patch
@@ -21,8 +21,6 @@ V2: Drop useless "default n", thanks Sergei :)
drivers/usb/host/Kconfig | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
-diff --git a/drivers/usb/host/Kconfig b/drivers/usb/host/Kconfig
-index 197a6a3..688698a 100644
--- a/drivers/usb/host/Kconfig
+++ b/drivers/usb/host/Kconfig
@@ -32,7 +32,14 @@ config USB_XHCI_PCI
@@ -41,6 +39,3 @@ index 197a6a3..688698a 100644
config USB_XHCI_MVEBU
tristate "xHCI support for Marvell Armada 375/38x"
---
-1.8.4.5
-
diff --git a/target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch b/target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch
index f09875c02c..2b0b42f2c3 100644
--- a/target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch
+++ b/target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch
@@ -140,7 +140,7 @@
err = br_ip6_multicast_add_group(br, port, &grec->grec_mca,
- vid);
+ vid, src);
- if (!err)
+ if (err)
break;
}
@@ -1407,7 +1434,8 @@ br_multicast_leave_group(struct net_brid
diff --git a/target/linux/generic/patches-4.0/653-disable_netlink_trim.patch b/target/linux/generic/patches-4.0/653-disable_netlink_trim.patch
index f3231db093..02ab826aed 100644
--- a/target/linux/generic/patches-4.0/653-disable_netlink_trim.patch
+++ b/target/linux/generic/patches-4.0/653-disable_netlink_trim.patch
@@ -1,6 +1,6 @@
--- a/net/netlink/af_netlink.c
+++ b/net/netlink/af_netlink.c
-@@ -1710,27 +1710,7 @@ void netlink_detachskb(struct sock *sk,
+@@ -1713,27 +1713,7 @@ void netlink_detachskb(struct sock *sk,
static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
{
diff --git a/target/linux/generic/patches-4.0/664-codel_fix_3_12.patch b/target/linux/generic/patches-4.0/664-codel_fix_3_12.patch
index 2682441b1c..726c428e56 100644
--- a/target/linux/generic/patches-4.0/664-codel_fix_3_12.patch
+++ b/target/linux/generic/patches-4.0/664-codel_fix_3_12.patch
@@ -1,6 +1,6 @@
--- a/net/sched/sch_api.c
+++ b/net/sched/sch_api.c
-@@ -1945,7 +1945,7 @@ static int __init pktsched_init(void)
+@@ -1947,7 +1947,7 @@ static int __init pktsched_init(void)
return err;
}
diff --git a/target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch b/target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch
index ea47d3bf0c..b283bbd3f6 100644
--- a/target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch
+++ b/target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch
@@ -1,6 +1,6 @@
--- a/drivers/usb/host/Kconfig
+++ b/drivers/usb/host/Kconfig
-@@ -306,6 +306,13 @@ config USB_OCTEON_EHCI
+@@ -313,6 +313,13 @@ config USB_OCTEON_EHCI
USB 2.0 device support. All CN6XXX based chips with USB are
supported.