summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-07-16 03:26:40 +0000
committerRod Whitby <rod@whitby.id.au>2007-07-16 03:26:40 +0000
commit81c3675f943a709622cddd400b8fe31a08b083cb (patch)
tree6808f1e62ed961ad044b17b710b87b5cbebdfb42
parent6d5c8233af982eb069e6f62d94e356fd44406624 (diff)
downloadmaster-31e0f0ae-81c3675f943a709622cddd400b8fe31a08b083cb.tar.gz
master-31e0f0ae-81c3675f943a709622cddd400b8fe31a08b083cb.tar.bz2
master-31e0f0ae-81c3675f943a709622cddd400b8fe31a08b083cb.zip
ixp4xx-2.6: Remove the inadequate netconfig script (which doesn't work on the only machines that it was meant to support), to allow ixp4xx images to behave like all other OpenWrt images
SVN-Revision: 7990
-rw-r--r--target/linux/ixp4xx-2.6/base-files.mk5
-rwxr-xr-xtarget/linux/ixp4xx-2.6/base-files/default/etc/init.d/netconfig84
2 files changed, 0 insertions, 89 deletions
diff --git a/target/linux/ixp4xx-2.6/base-files.mk b/target/linux/ixp4xx-2.6/base-files.mk
deleted file mode 100644
index d6682bd388..0000000000
--- a/target/linux/ixp4xx-2.6/base-files.mk
+++ /dev/null
@@ -1,5 +0,0 @@
-define Package/base-files/install-target
- rm -f $(1)/etc/config/network
-endef
-
-
diff --git a/target/linux/ixp4xx-2.6/base-files/default/etc/init.d/netconfig b/target/linux/ixp4xx-2.6/base-files/default/etc/init.d/netconfig
deleted file mode 100755
index ded5f4b8d6..0000000000
--- a/target/linux/ixp4xx-2.6/base-files/default/etc/init.d/netconfig
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-
-START=15
-
-# hardware
-# the 'Hardware' string from cpuinfo
-hardware(){
- sed -n 's!^Hardware *: !!p' /proc/cpuinfo
-}
-#
-# machine
-# outputs an identifier of the current machine - i.e. the board
-# slugos is running on.
-machine(){
- case "$(hardware)" in
- *Avila*) echo avila;;
- *Loft*) echo loft;;
- *NAS?100d*) echo nas100d;;
- *DSM?G600*) echo dsmg600;;
- *NSLU2*) echo nslu2;;
- *FSG?3*) echo fsg3;;
- *Gateway?7001*) echo gateway7001;;
- *) echo unknown;;
- esac
-}
-
-start() {
- [ -e /etc/config/network ] && exit 0
-
- mkdir -p /etc/config
-
- (
- case "$(machine)" in
- nslu2)
- sysconf=$(find_mtd_part "SysConf")
- echo model=nslu2
- strings $sysconf ;;
- nas100d)
- sysconf=$(find_mtd_part "sysconfig")
- echo model=nas100d
- strings $sysconf ;;
- *)
- echo model=$(machine) ;;
- esac
- ) | awk '
- function p(cfgname, name) {
- if (c[name] != "") print " option " cfgname " \"" c[name] "\""
- }
-
- BEGIN {
- FS="="
- }
-
- { c[$1] = $2 }
-
- END {
- print "#### Loopback configuration"
- print "config interface loopback"
- print " option ifname \"lo\""
- print " option proto static"
- print " option ipaddr 127.0.0.1"
- print " option netmask 255.0.0.0"
- print ""
- print ""
- print "#### LAN configuration"
- print "config interface lan"
- print " option ifname \"eth0\""
- if ((c["model"] == "nslu2") || (c["model"] == "nas100d")) {
- p("proto", "bootproto")
- p("ipaddr", "ip_addr")
- p("netmask", "netmask")
- p("gateway", "gateway")
- p("dns", "dns_server1")
- p("hostname", "disk_server_name")
- }
- else {
- print " option proto dhcp"
- }
- }' > /etc/config/network
-
- ifup loopback
- ifup lan
-}