summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-01 09:17:09 +0000
committerJohn Crispin <john@openwrt.org>2016-03-01 09:17:09 +0000
commit7d008e8bf092ac366d46c4255ef4828ed6315b99 (patch)
tree02efc9f8be1aac54f794efb353f74e2400e09842
parent96eb5c6fa8ead2bf749b78dff2f55a340cff020e (diff)
downloadmaster-31e0f0ae-7d008e8bf092ac366d46c4255ef4828ed6315b99.tar.gz
master-31e0f0ae-7d008e8bf092ac366d46c4255ef4828ed6315b99.tar.bz2
master-31e0f0ae-7d008e8bf092ac366d46c4255ef4828ed6315b99.zip
ar71xx: Add OOLITE to the Gainstrong profile, removed standalone profile.
This patch moves the OOLITE profile code into the overarching Gainstrong profile and deletes the old single profile file. Signed-off by: Stijn Segers <francesco.borromini@inventati.org> SVN-Revision: 48866
-rw-r--r--target/linux/ar71xx/generic/profiles/gainstrong.mk11
-rw-r--r--target/linux/ar71xx/generic/profiles/oolite.mk18
2 files changed, 11 insertions, 18 deletions
diff --git a/target/linux/ar71xx/generic/profiles/gainstrong.mk b/target/linux/ar71xx/generic/profiles/gainstrong.mk
index a82529ddf1..8f7a48506e 100644
--- a/target/linux/ar71xx/generic/profiles/gainstrong.mk
+++ b/target/linux/ar71xx/generic/profiles/gainstrong.mk
@@ -15,3 +15,14 @@ define Profile/MINIBOXV1/Description
Package set optimized for the Gainstrong MiniBox V1.0
endef
$(eval $(call Profile,MINIBOXV1))
+
+define Profile/OOLITE
+ NAME:=Gainstrong OOLITE
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+
+define Profile/OOLITE/Description
+ Package set optimized for the Gainstrong OOLITE.
+endef
+$(eval $(call Profile,OOLITE))
diff --git a/target/linux/ar71xx/generic/profiles/oolite.mk b/target/linux/ar71xx/generic/profiles/oolite.mk
deleted file mode 100644
index 448f08d693..0000000000
--- a/target/linux/ar71xx/generic/profiles/oolite.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/OOLITE
- NAME:=OOLITE
- PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
-endef
-
-
-define Profile/OOLITE/Description
- Package set optimized for the OOLITE.
-endef
-$(eval $(call Profile,OOLITE))
-