summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-08-04 19:23:47 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-04 20:53:02 +0200
commit7c874d18f51cb952babd8241fae5a8286dc68878 (patch)
tree491165a180d2f8976803798b82069dbb7aa5fbed
parent93fb6ce05b1e161a8a5485e006e5fe05fc060fd3 (diff)
downloadmaster-31e0f0ae-7c874d18f51cb952babd8241fae5a8286dc68878.tar.gz
master-31e0f0ae-7c874d18f51cb952babd8241fae5a8286dc68878.tar.bz2
master-31e0f0ae-7c874d18f51cb952babd8241fae5a8286dc68878.zip
kernel: mark compression modules as hiddden to obsolete the compressor kconfig hack
Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--package/kernel/linux/modules/lib.mk3
-rw-r--r--target/linux/generic/patches-3.18/262-compressor_kconfig_hack.patch35
-rw-r--r--target/linux/generic/patches-4.1/262-compressor_kconfig_hack.patch35
-rw-r--r--target/linux/generic/patches-4.4/262-compressor_kconfig_hack.patch36
4 files changed, 3 insertions, 106 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index 9d35e42e24..c5148ce487 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -104,6 +104,7 @@ define KernelPackage/lib-lzo
KCONFIG:= \
CONFIG_LZO_COMPRESS \
CONFIG_LZO_DECOMPRESS
+ HIDDEN:=1
FILES:= \
$(LINUX_DIR)/lib/lzo/lzo_compress.ko \
$(LINUX_DIR)/lib/lzo/lzo_decompress.ko
@@ -120,6 +121,7 @@ $(eval $(call KernelPackage,lib-lzo))
define KernelPackage/lib-lz4
SUBMENU:=$(LIB_MENU)
TITLE:=LZ4 support
+ HIDDEN:=1
KCONFIG:= \
CONFIG_LZ4_COMPRESS \
CONFIG_LZ4_DECOMPRESS
@@ -196,6 +198,7 @@ $(eval $(call KernelPackage,lib-textsearch))
define KernelPackage/lib-zlib
SUBMENU:=$(LIB_MENU)
TITLE:=Zlib support
+ HIDDEN:=1
KCONFIG:= \
CONFIG_ZLIB_DEFLATE \
CONFIG_ZLIB_INFLATE
diff --git a/target/linux/generic/patches-3.18/262-compressor_kconfig_hack.patch b/target/linux/generic/patches-3.18/262-compressor_kconfig_hack.patch
deleted file mode 100644
index 51b4fc89b6..0000000000
--- a/target/linux/generic/patches-3.18/262-compressor_kconfig_hack.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -205,25 +205,25 @@ config RANDOM32_SELFTEST
- # compression support is select'ed if needed
- #
- config ZLIB_INFLATE
-- tristate
-+ tristate "ZLIB inflate support"
-
- config ZLIB_DEFLATE
-- tristate
-+ tristate "ZLIB deflate support"
-
- config LZO_COMPRESS
-- tristate
-+ tristate "LZO compress support"
-
- config LZO_DECOMPRESS
-- tristate
-+ tristate "LZO decompress support"
-
- config LZ4_COMPRESS
-- tristate
-+ tristate "LZ4 compress support"
-
- config LZ4HC_COMPRESS
-- tristate
-+ tristate "LZ4HC compress support"
-
- config LZ4_DECOMPRESS
-- tristate
-+ tristate "LZ4 decompress support"
-
- source "lib/xz/Kconfig"
-
diff --git a/target/linux/generic/patches-4.1/262-compressor_kconfig_hack.patch b/target/linux/generic/patches-4.1/262-compressor_kconfig_hack.patch
deleted file mode 100644
index 771c1671a8..0000000000
--- a/target/linux/generic/patches-4.1/262-compressor_kconfig_hack.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -213,25 +213,25 @@ config RANDOM32_SELFTEST
- # compression support is select'ed if needed
- #
- config ZLIB_INFLATE
-- tristate
-+ tristate "ZLIB inflate support"
-
- config ZLIB_DEFLATE
-- tristate
-+ tristate "ZLIB deflate support"
-
- config LZO_COMPRESS
-- tristate
-+ tristate "LZO compress support"
-
- config LZO_DECOMPRESS
-- tristate
-+ tristate "LZO decompress support"
-
- config LZ4_COMPRESS
-- tristate
-+ tristate "LZ4 compress support"
-
- config LZ4HC_COMPRESS
-- tristate
-+ tristate "LZ4HC compress support"
-
- config LZ4_DECOMPRESS
-- tristate
-+ tristate "LZ4 decompress support"
-
- source "lib/xz/Kconfig"
-
diff --git a/target/linux/generic/patches-4.4/262-compressor_kconfig_hack.patch b/target/linux/generic/patches-4.4/262-compressor_kconfig_hack.patch
deleted file mode 100644
index edb9ff7cd1..0000000000
--- a/target/linux/generic/patches-4.4/262-compressor_kconfig_hack.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -218,26 +218,26 @@ config 842_DECOMPRESS
- tristate
-
- config ZLIB_INFLATE
-- tristate
-+ tristate "ZLIB inflate support"
-
- config ZLIB_DEFLATE
-- tristate
-+ tristate "ZLIB deflate support"
- select BITREVERSE
-
- config LZO_COMPRESS
-- tristate
-+ tristate "LZO compress support"
-
- config LZO_DECOMPRESS
-- tristate
-+ tristate "LZO decompress support"
-
- config LZ4_COMPRESS
-- tristate
-+ tristate "LZ4 compress support"
-
- config LZ4HC_COMPRESS
-- tristate
-+ tristate "LZ4HC compress support"
-
- config LZ4_DECOMPRESS
-- tristate
-+ tristate "LZ4 decompress support"
-
- source "lib/xz/Kconfig"
-