summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-07-01 10:52:35 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-07-01 10:52:35 +0000
commit7c197d9f0e7418b53e184f0b1a2112bed525454f (patch)
tree00d774557af00275ffc36342023df1d3f158eb47
parent5986a18c16fe7035e1ec5a2474a47d0b13ea9383 (diff)
downloadmaster-31e0f0ae-7c197d9f0e7418b53e184f0b1a2112bed525454f.tar.gz
master-31e0f0ae-7c197d9f0e7418b53e184f0b1a2112bed525454f.tar.bz2
master-31e0f0ae-7c197d9f0e7418b53e184f0b1a2112bed525454f.zip
hostapd: truncate default mac file before adding entries to it (#13797)
SVN-Revision: 37114
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index d3447dfca0..e7150396e8 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
PKG_VERSION:=20130630
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_REV:=9e6a321815f924e1e42896538d639e62d7786f6a
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index 8d6f30538d..94f75c1c95 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -220,7 +220,9 @@ hostapd_set_bss_options() {
if [ -z "$macfile" ]
then
# if no macfile has been specified, fallback to the default name
+ # and truncate file to avoid aggregating entries over time
macfile="/var/run/hostapd-$ifname.maclist"
+ echo "" > "$macfile"
else
if [ -n "$maclist" ]
then