summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-08-25 06:36:06 +0000
committerJohn Crispin <john@openwrt.org>2014-08-25 06:36:06 +0000
commit7a1f4c50fa052bc40116f9e243ab15f0fba1ebf2 (patch)
tree341f5772aeba357780c482f35b05ab64c387d3c6
parentbbcf1fa610aa0029b58c0c2c69c03f8ac1f9160d (diff)
downloadmaster-31e0f0ae-7a1f4c50fa052bc40116f9e243ab15f0fba1ebf2.tar.gz
master-31e0f0ae-7a1f4c50fa052bc40116f9e243ab15f0fba1ebf2.tar.bz2
master-31e0f0ae-7a1f4c50fa052bc40116f9e243ab15f0fba1ebf2.zip
PKG_CHECK_FORMAT_SECURITY: add a menuconfig option, disable by default
The idea is still to enable it by default at some point I've tested all ar71xx packages (except oldpackages) using CONFIG_ALL=y Failing packages have been marked with PKG_CHECK_FORMAT_SECURITY:=0 for now I can test more targets but i have no idea which are the most used Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com> SVN-Revision: 42282
-rw-r--r--config/Config-build.in9
-rw-r--r--include/package.mk8
2 files changed, 14 insertions, 3 deletions
diff --git a/config/Config-build.in b/config/Config-build.in
index 371ae7632a..02fe136791 100644
--- a/config/Config-build.in
+++ b/config/Config-build.in
@@ -93,6 +93,15 @@ menu "Global build settings"
If you are unsure, select N.
+ config PKG_CHECK_FORMAT_SECURITY
+ bool
+ prompt "Enable gcc format-security"
+ default n
+ help
+ Add -Wformat -Werror=format-security to the CFLAGS
+ You can disable this per package by adding
+ PKG_CHECK_FORMAT_SECURITY:=0 in the package Makefile
+
config PKG_BUILD_USE_JOBSERVER
bool
prompt "Use top-level make jobserver for packages"
diff --git a/include/package.mk b/include/package.mk
index 88ec3ef57f..1cdab6b447 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -14,7 +14,7 @@ PKG_INSTALL_DIR ?= $(PKG_BUILD_DIR)/ipkg-install
PKG_MD5SUM ?= unknown
PKG_BUILD_PARALLEL ?=
PKG_USE_MIPS16 ?= 1
-PKG_CHECK_FORMAT_SECURITY ?= 0
+PKG_CHECK_FORMAT_SECURITY ?= 1
ifneq ($(CONFIG_PKG_BUILD_USE_JOBSERVER),)
MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) -j)
@@ -34,8 +34,10 @@ ifdef CONFIG_USE_MIPS16
TARGET_CFLAGS += -mips16 -minterlink-mips16
endif
endif
-ifeq ($(strip $(PKG_CHECK_FORMAT_SECURITY)),1)
- TARGET_CFLAGS += -Wformat -Werror=format-security
+ifdef CONFIG_PKG_CHECK_FORMAT_SECURITY
+ ifeq ($(strip $(PKG_CHECK_FORMAT_SECURITY)),1)
+ TARGET_CFLAGS += -Wformat -Werror=format-security
+ endif
endif
include $(INCLUDE_DIR)/prereq.mk