summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-28 14:27:03 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-28 14:27:03 +0000
commit7992df37218c014ba57d454f1704a27438fbf3b9 (patch)
tree2b2b20f3c7ee1c4bb3a54af8e765cf6093194656
parent2765e3b7ff867e3223d3fb7504a517ada760ecfc (diff)
downloadmaster-31e0f0ae-7992df37218c014ba57d454f1704a27438fbf3b9.tar.gz
master-31e0f0ae-7992df37218c014ba57d454f1704a27438fbf3b9.tar.bz2
master-31e0f0ae-7992df37218c014ba57d454f1704a27438fbf3b9.zip
images: allow generating .cpio.gz and/or .tar.gz archives whether ramdisk is selected or not
SVN-Revision: 21237
-rw-r--r--Config.in2
-rw-r--r--include/image.mk23
2 files changed, 12 insertions, 13 deletions
diff --git a/Config.in b/Config.in
index ffe1147f44..4746ba4185 100644
--- a/Config.in
+++ b/Config.in
@@ -63,14 +63,12 @@ menu "Target Images"
config TARGET_ROOTFS_TGZ
bool "tgz"
default y if USES_TGZ
- depends !TARGET_ROOTFS_INITRAMFS
help
Build a compressed tar archive of the the root filesystem
config TARGET_ROOTFS_CPIOGZ
bool "cpiogz"
default y if USES_CPIOGZ
- depends !TARGET_ROOTFS_INITRAMFS
help
Build a compressed cpio archive of the the root filesystem
diff --git a/include/image.mk b/include/image.mk
index 34453f460a..8dc7e114b6 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -95,17 +95,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
endef
endif
- ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
- define Image/mkfs/tgz
- $(TAR) -zcf $(BIN_DIR)/$(IMG_PREFIX)-rootfs.tgz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
- endef
- endif
-
- ifeq ($(CONFIG_TARGET_ROOTFS_CPIOGZ),y)
- define Image/mkfs/cpiogz
- ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
- endef
- endif
ifeq ($(CONFIG_TARGET_ROOTFS_UBIFS),y)
define Image/mkfs/ubifs
$(CP) ./ubinize.cfg $(KDIR)
@@ -130,6 +119,18 @@ define Image/Checksum
endef
+ifeq ($(CONFIG_TARGET_ROOTFS_CPIOGZ),y)
+ define Image/mkfs/cpiogz
+ ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
+ endef
+endif
+
+ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
+ define Image/mkfs/tgz
+ $(TAR) -zcf $(BIN_DIR)/$(IMG_PREFIX)-rootfs.tgz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
+ endef
+endif
+
ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))