summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-09-12 15:31:00 +0000
committerMichael Büsch <mb@bu3sch.de>2010-09-12 15:31:00 +0000
commit78539bfa4f6e2af404934fee326d607e6414980e (patch)
treef7cf1a4b67361c5c11359b4d72914fd9d10d26bb
parent0c4abfba31ea3f132c69e6233633d9d301e6949a (diff)
downloadmaster-31e0f0ae-78539bfa4f6e2af404934fee326d607e6414980e.tar.gz
master-31e0f0ae-78539bfa4f6e2af404934fee326d607e6414980e.tar.bz2
master-31e0f0ae-78539bfa4f6e2af404934fee326d607e6414980e.zip
Fix compilation of crypto modules. This fixes #7920
SVN-Revision: 23028
-rw-r--r--package/kernel/modules/crypto.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 1ec540be1b..3be3afdcaa 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -22,9 +22,9 @@ SHA256_SUFFIX:=$(CRYPTO_GENERIC)
SHA512_SUFFIX:=$(CRYPTO_GENERIC)
CRYPTO_MODULES = \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),ALGAPI2,ALGAPI)=crypto_algapi \
+ $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),ALGAPI2,ALGAPI)=crypto_algapi \
AEAD2=aead \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),PCOMP2,PCOMP)=pcompress \
+ $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),PCOMP2,PCOMP)=pcompress \
BLKCIPHER2=crypto_blkcipher \
HASH2=crypto_hash \
MANAGER2=cryptomgr \