summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-03-01 23:16:17 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2016-03-01 23:16:17 +0000
commit7768735873566d26a006c19e21d95d82e7117c31 (patch)
treef416bc26820d127f03a42e58cef93b3b5bd87160
parent25b34dd97fcb36350ac515469001e7c489521718 (diff)
downloadmaster-31e0f0ae-7768735873566d26a006c19e21d95d82e7117c31.tar.gz
master-31e0f0ae-7768735873566d26a006c19e21d95d82e7117c31.tar.bz2
master-31e0f0ae-7768735873566d26a006c19e21d95d82e7117c31.zip
kernel: update kernel 3.18 to version 3.18.27
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 48874
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch2
-rw-r--r--target/linux/generic/patches-3.18/662-use_fq_codel_by_default.patch2
-rw-r--r--target/linux/generic/patches-3.18/902-debloat_proc.patch2
-rw-r--r--target/linux/generic/patches-3.18/903-debloat_direct_io.patch2
-rw-r--r--target/linux/sunxi/patches-3.18/200-mmc-add-sdio-function-subnode.patch2
6 files changed, 7 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 3f4c71df9a..c159d10f1d 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,12 +2,12 @@
LINUX_RELEASE?=1
-LINUX_VERSION-3.18 = .26
+LINUX_VERSION-3.18 = .27
LINUX_VERSION-4.1 = .16
LINUX_VERSION-4.3 = .4
LINUX_VERSION-4.4 = .3
-LINUX_KERNEL_MD5SUM-3.18.26 = fb3ef8da32a25607807887b9567a6927
+LINUX_KERNEL_MD5SUM-3.18.27 = 015a01bf84e7c6bc9952551b4da45044
LINUX_KERNEL_MD5SUM-4.1.16 = e4bf22fed49b476b47acffc00c03267a
LINUX_KERNEL_MD5SUM-4.3.4 = 5275d02132107c28b85f986bad576d91
LINUX_KERNEL_MD5SUM-4.4.3 = 5feab5a2c016e186e3088d4fae963ed7
diff --git a/target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch b/target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch
index 6fbbc25ae0..1bcd5159db 100644
--- a/target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch
+++ b/target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch
@@ -44,7 +44,7 @@ Miklos
--- a/fs/overlayfs/copy_up.c
+++ b/fs/overlayfs/copy_up.c
-@@ -300,6 +300,9 @@ int ovl_copy_up_one(struct dentry *paren
+@@ -311,6 +311,9 @@ int ovl_copy_up_one(struct dentry *paren
struct cred *override_cred;
char *link = NULL;
diff --git a/target/linux/generic/patches-3.18/662-use_fq_codel_by_default.patch b/target/linux/generic/patches-3.18/662-use_fq_codel_by_default.patch
index ba7c384ad2..5caf933764 100644
--- a/target/linux/generic/patches-3.18/662-use_fq_codel_by_default.patch
+++ b/target/linux/generic/patches-3.18/662-use_fq_codel_by_default.patch
@@ -51,7 +51,7 @@
EXPORT_SYMBOL(default_qdisc_ops);
/* Main transmission queue. */
-@@ -737,7 +737,7 @@ static void attach_one_default_qdisc(str
+@@ -739,7 +739,7 @@ static void attach_one_default_qdisc(str
if (dev->tx_queue_len) {
qdisc = qdisc_create_dflt(dev_queue,
diff --git a/target/linux/generic/patches-3.18/902-debloat_proc.patch b/target/linux/generic/patches-3.18/902-debloat_proc.patch
index 024efe080b..79cecf90d4 100644
--- a/target/linux/generic/patches-3.18/902-debloat_proc.patch
+++ b/target/linux/generic/patches-3.18/902-debloat_proc.patch
@@ -1,6 +1,6 @@
--- a/fs/locks.c
+++ b/fs/locks.c
-@@ -2611,6 +2611,8 @@ static const struct file_operations proc
+@@ -2620,6 +2620,8 @@ static const struct file_operations proc
static int __init proc_locks_init(void)
{
diff --git a/target/linux/generic/patches-3.18/903-debloat_direct_io.patch b/target/linux/generic/patches-3.18/903-debloat_direct_io.patch
index 92190e47a9..dbb08ca4e7 100644
--- a/target/linux/generic/patches-3.18/903-debloat_direct_io.patch
+++ b/target/linux/generic/patches-3.18/903-debloat_direct_io.patch
@@ -26,7 +26,7 @@
endif
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
-@@ -2528,12 +2528,25 @@ enum {
+@@ -2529,12 +2529,25 @@ enum {
DIO_ASYNC_EXTEND = 0x04,
};
diff --git a/target/linux/sunxi/patches-3.18/200-mmc-add-sdio-function-subnode.patch b/target/linux/sunxi/patches-3.18/200-mmc-add-sdio-function-subnode.patch
index 96662d81d0..dcbb3a4767 100644
--- a/target/linux/sunxi/patches-3.18/200-mmc-add-sdio-function-subnode.patch
+++ b/target/linux/sunxi/patches-3.18/200-mmc-add-sdio-function-subnode.patch
@@ -49,7 +49,7 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
put_device(&card->dev);
--- a/drivers/mmc/core/core.c
+++ b/drivers/mmc/core/core.c
-@@ -1207,6 +1207,34 @@ EXPORT_SYMBOL(mmc_of_parse_voltage);
+@@ -1231,6 +1231,34 @@ EXPORT_SYMBOL(mmc_of_parse_voltage);
#endif /* CONFIG_OF */