summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 16:51:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 16:51:25 +0000
commit7283cec9a656e171b59fb0f3a7ac954682cdc4df (patch)
tree875cca32b8e09aaa631e2cfb83cc28a837e438fe
parentca61154ca053958b6be1d03f1b3122748eec60d4 (diff)
downloadmaster-31e0f0ae-7283cec9a656e171b59fb0f3a7ac954682cdc4df.tar.gz
master-31e0f0ae-7283cec9a656e171b59fb0f3a7ac954682cdc4df.tar.bz2
master-31e0f0ae-7283cec9a656e171b59fb0f3a7ac954682cdc4df.zip
fix mtd-utils compile on freebsd
SVN-Revision: 5020
-rw-r--r--openwrt/tools/include/endian.h5
-rw-r--r--openwrt/tools/mtd-utils/Makefile2
2 files changed, 6 insertions, 1 deletions
diff --git a/openwrt/tools/include/endian.h b/openwrt/tools/include/endian.h
index 4ea34cdd0f..9bfc652b90 100644
--- a/openwrt/tools/include/endian.h
+++ b/openwrt/tools/include/endian.h
@@ -9,6 +9,11 @@
#define bswap_16(x) NXSwapShort(x)
#define bswap_32(x) NXSwapInt(x)
#define bswap_64(x) NXSwapLongLong(x)
+#elif defined(__FreeBSD__)
+#include <sys/endian.h>
+#define bswap_16(x) bswap16(x)
+#define bswap_32(x) bswap32(x)
+#define bswap_64(x) bswap64(x)
#else
#include <machine/endian.h>
#define bswap_16(x) swap16(x)
diff --git a/openwrt/tools/mtd-utils/Makefile b/openwrt/tools/mtd-utils/Makefile
index 55dd88a785..f67ccf758f 100644
--- a/openwrt/tools/mtd-utils/Makefile
+++ b/openwrt/tools/mtd-utils/Makefile
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/host-build.mk
CFLAGS := $(HOSTCFLAGS) -O2 -I../include
ifneq ($(OS),Linux)
-CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h
+CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h -include endian.h
endif
define Build/Compile