summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-09 20:15:02 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-09 20:15:02 +0000
commit70dff7070ed289d1fd8078a3bf80713ed959b20d (patch)
treeefc1f76e9f5c7e69a16c8017cfcf57f9ca453ac4
parent7a54becd63b4a572183ce4a8afc883e3dfdc1288 (diff)
downloadmaster-31e0f0ae-70dff7070ed289d1fd8078a3bf80713ed959b20d.tar.gz
master-31e0f0ae-70dff7070ed289d1fd8078a3bf80713ed959b20d.tar.bz2
master-31e0f0ae-70dff7070ed289d1fd8078a3bf80713ed959b20d.zip
uhttpd: break tight loop when receiving eof during header reading (#7904)
SVN-Revision: 22988
-rw-r--r--package/uhttpd/Makefile2
-rw-r--r--package/uhttpd/src/uhttpd.c4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index 086c294580..e37fa90ec4 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=17
+PKG_RELEASE:=18
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_BUILD_DEPENDS := libcyassl liblua
diff --git a/package/uhttpd/src/uhttpd.c b/package/uhttpd/src/uhttpd.c
index 6f5e616345..a818e1c450 100644
--- a/package/uhttpd/src/uhttpd.c
+++ b/package/uhttpd/src/uhttpd.c
@@ -401,6 +401,10 @@ static struct http_request * uh_http_header_recv(struct client *cl)
{
ensure_out(rlen = uh_tcp_recv(cl, bufptr, rlen));
+ /* unexpected eof - #7904 */
+ if( rlen == 0 )
+ return NULL;
+
blen -= rlen;
bufptr += rlen;
}