summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2009-03-06 21:12:14 +0000
committerMirko Vogt <mirko@openwrt.org>2009-03-06 21:12:14 +0000
commit7028d414a39b35d686754cecac8af0de1ca02b01 (patch)
tree95734488ea2f2c7f6cd8e5281ce731cd8337390b
parentaebd1654e943404ef120413e07ce79a2afb65245 (diff)
downloadmaster-31e0f0ae-7028d414a39b35d686754cecac8af0de1ca02b01.tar.gz
master-31e0f0ae-7028d414a39b35d686754cecac8af0de1ca02b01.tar.bz2
master-31e0f0ae-7028d414a39b35d686754cecac8af0de1ca02b01.zip
prepare target for use with EABI
SVN-Revision: 14766
-rw-r--r--target/linux/s3c24xx/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/s3c24xx/Makefile b/target/linux/s3c24xx/Makefile
index 309c176cfd..33c7a55480 100644
--- a/target/linux/s3c24xx/Makefile
+++ b/target/linux/s3c24xx/Makefile
@@ -19,6 +19,12 @@ define Target/Description
OpenMoko gta02
endef
+define Kernel/Configure
+ $(call Kernel/Configure/Default)
+ $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+ $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
include $(INCLUDE_DIR)/target.mk
$(eval $(call BuildTarget))