summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-09-22 18:00:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-09-22 18:00:35 +0000
commit6f4e700acd737903c12fee0f0790f84c39a28a19 (patch)
treeb1b28158e4f1c35a90d975f3362cd23d4cd360cd
parent0754070949d428bf409e38b084431a9910d7b72a (diff)
downloadmaster-31e0f0ae-6f4e700acd737903c12fee0f0790f84c39a28a19.tar.gz
master-31e0f0ae-6f4e700acd737903c12fee0f0790f84c39a28a19.tar.bz2
master-31e0f0ae-6f4e700acd737903c12fee0f0790f84c39a28a19.zip
when using -O2 instead of -Os, get rid of the two optimizations that are causing most of the extra bloat. brings kernel size close to the -Os size again
SVN-Revision: 17679
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/004-extra_optimization.patch9
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch9
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/004-extra_optimization.patch9
3 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.28/004-extra_optimization.patch
index d6866899c3..8827ed0c3d 100644
--- a/target/linux/generic-2.6/patches-2.6.28/004-extra_optimization.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/004-extra_optimization.patch
@@ -1,5 +1,14 @@
--- a/Makefile
+++ b/Makefile
+@@ -512,7 +512,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS += -Os
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
@@ -549,6 +549,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
diff --git a/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
index 018e673e20..0b5174cbbd 100644
--- a/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
+++ b/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
@@ -1,5 +1,14 @@
--- a/Makefile
+++ b/Makefile
+@@ -529,7 +529,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS += -Os
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
@@ -567,6 +567,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
diff --git a/target/linux/generic-2.6/patches-2.6.31/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.31/004-extra_optimization.patch
index 333acb612b..e0ba51598e 100644
--- a/target/linux/generic-2.6/patches-2.6.31/004-extra_optimization.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/004-extra_optimization.patch
@@ -1,5 +1,14 @@
--- a/Makefile
+++ b/Makefile
+@@ -521,7 +521,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS += -Os
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
@@ -559,6 +559,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)