summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 16:58:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 16:58:47 +0000
commit6d7097f89976fee9da23ef798d687e9b0d57f276 (patch)
tree79dcc1b4024b9fb9eca8a1014c7eb1c8f6f1c3ad
parent7283cec9a656e171b59fb0f3a7ac954682cdc4df (diff)
downloadmaster-31e0f0ae-6d7097f89976fee9da23ef798d687e9b0d57f276.tar.gz
master-31e0f0ae-6d7097f89976fee9da23ef798d687e9b0d57f276.tar.bz2
master-31e0f0ae-6d7097f89976fee9da23ef798d687e9b0d57f276.zip
move the common variables from host-build.mk to host.mk
SVN-Revision: 5021
-rw-r--r--openwrt/include/host-build.mk19
-rw-r--r--openwrt/include/host.mk24
2 files changed, 25 insertions, 18 deletions
diff --git a/openwrt/include/host-build.mk b/openwrt/include/host-build.mk
index 5670b6f17d..a1287da475 100644
--- a/openwrt/include/host-build.mk
+++ b/openwrt/include/host-build.mk
@@ -5,24 +5,7 @@
# See /LICENSE for more information.
#
-include $(TOPDIR)/.host.mk
-
-$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host-build.mk
- echo "HOST_OS:=`uname`" > $@
- echo "HOST_ARCH:=` \
- $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
- -e 's/sparc.*/sparc/' \
- -e 's/arm.*/arm/' \
- -e 's/m68k.*/m68k/' \
- -e 's/ppc/powerpc/' \
- -e 's/v850.*/v850/' \
- -e 's/sh[234]/sh/' \
- -e 's/mips-.*/mips/' \
- -e 's/mipsel-.*/mipsel/' \
- -e 's/cris.*/cris/' \
- -e 's/i[3-9]86/i386/'`" >> $@
- echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
-
+include $(INCLUDE_DIR)/host.mk
ifneq ($(strip $(PKG_CAT)),)
ifeq ($(PKG_CAT),unzip)
diff --git a/openwrt/include/host.mk b/openwrt/include/host.mk
new file mode 100644
index 0000000000..b4580e2b7a
--- /dev/null
+++ b/openwrt/include/host.mk
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/.host.mk
+
+$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
+ echo "HOST_OS:=`uname`" > $@
+ echo "HOST_ARCH:=` \
+ $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
+ -e 's/sparc.*/sparc/' \
+ -e 's/arm.*/arm/' \
+ -e 's/m68k.*/m68k/' \
+ -e 's/ppc/powerpc/' \
+ -e 's/v850.*/v850/' \
+ -e 's/sh[234]/sh/' \
+ -e 's/mips-.*/mips/' \
+ -e 's/mipsel-.*/mipsel/' \
+ -e 's/cris.*/cris/' \
+ -e 's/i[3-9]86/i386/'`" >> $@
+ echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@