summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2012-12-13 18:57:38 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2012-12-13 18:57:38 +0000
commit6c8efbfdc08ad244e7e61dbdafe5c34977ffadbd (patch)
tree216ecf20e2bc2d0e9d0765621583ec7dc1142dc7
parent588b42a8b792891e2ff4efc10eb74d5ef6659d21 (diff)
downloadmaster-31e0f0ae-6c8efbfdc08ad244e7e61dbdafe5c34977ffadbd.tar.gz
master-31e0f0ae-6c8efbfdc08ad244e7e61dbdafe5c34977ffadbd.tar.bz2
master-31e0f0ae-6c8efbfdc08ad244e7e61dbdafe5c34977ffadbd.zip
brcm47xx: Additional BCM4716 support
Additional BCM4716 support. Still needs working ethernet driver. Signed-off-by: Nathan Hintz <nlhintz@hotmail.com> SVN-Revision: 34672
-rwxr-xr-xtarget/linux/brcm47xx/base-files/etc/init.d/netconfig6
-rw-r--r--target/linux/brcm47xx/image/Makefile2
2 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/base-files/etc/init.d/netconfig b/target/linux/brcm47xx/base-files/etc/init.d/netconfig
index fb41ddd7c5..b4840c2c41 100755
--- a/target/linux/brcm47xx/base-files/etc/init.d/netconfig
+++ b/target/linux/brcm47xx/base-files/etc/init.d/netconfig
@@ -165,6 +165,12 @@ start() {
c["vlan1ports"] = "0 8"
}
+ # generic broadcom 4716 processor with 53115 switch
+ if (nvram["boardtype"] == "0x04cf") {
+ c["vlan0ports"] = "1 2 3 4 8*"
+ c["vlan1ports"] = "0 8"
+ }
+
# WAP54G
if ((nvram["boardnum"] == "2") || \
(nvram["boardnum"] == "1024")) {
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 871175ed40..f45fb56a92 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -91,6 +91,8 @@ define Image/Build/jffs2-64k
$(call Image/Build/CyberTAN,$(1),wrt300n_v11,EWC2,1.51.2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/CyberTAN,$(1),wrt350n_v1,EWCG,1.04.1,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/CyberTAN,$(1),wrt610n_v1,610N,1.0.1,$(patsubst jffs2-%,jffs2,$(1)))
+# $(call Image/Build/CyberTAN,$(1),wrt610n_v2,610N,2.0.0,$(patsubst jffs2-%,jffs2,$(1)))
+# $(call Image/Build/CyberTAN,$(1),e3000_v1,61XN,1.0.3,$(patsubst jffs2-%,jffs2,$(1)))
# $(call Image/Build/CyberTAN,$(1),e3200_v1,3200,1.0.1,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Motorola,$(1),wa840g,2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Motorola,$(1),we800g,3,$(patsubst jffs2-%,jffs2,$(1)))