summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-05-02 11:46:53 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-05-02 11:46:53 +0000
commit6ac2b3b76a728fe75d6b2014bfdeeeb7f39fa4b9 (patch)
tree21f5a5e0faead88e4497f8142f98275d8f653a77
parent7f2743d45852d345f20809f1c24d1c197583b5d3 (diff)
downloadmaster-31e0f0ae-6ac2b3b76a728fe75d6b2014bfdeeeb7f39fa4b9.tar.gz
master-31e0f0ae-6ac2b3b76a728fe75d6b2014bfdeeeb7f39fa4b9.tar.bz2
master-31e0f0ae-6ac2b3b76a728fe75d6b2014bfdeeeb7f39fa4b9.zip
atheros: remove static gpio_request() from board setup and include generic kmod-gpio-button-hotplug instead.
This change is based on a patch by Karl Palsson <karlp@remake.is> See http://patchwork.openwrt.org/patch/3536/. SVN-Revision: 36513
-rw-r--r--target/linux/atheros/Makefile4
-rw-r--r--target/linux/atheros/patches-3.8/100-board.patch4
2 files changed, 3 insertions, 5 deletions
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
index c7e9f84e43..1748f24474 100644
--- a/target/linux/atheros/Makefile
+++ b/target/linux/atheros/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,7 +15,7 @@ LINUX_VERSION:=3.8.11
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
define Target/Description
Build firmware images for Atheros SoC boards
diff --git a/target/linux/atheros/patches-3.8/100-board.patch b/target/linux/atheros/patches-3.8/100-board.patch
index 56c1f6943d..8663156ade 100644
--- a/target/linux/atheros/patches-3.8/100-board.patch
+++ b/target/linux/atheros/patches-3.8/100-board.patch
@@ -2106,7 +2106,7 @@
+
--- /dev/null
+++ b/arch/mips/ar231x/ar2315.c
-@@ -0,0 +1,694 @@
+@@ -0,0 +1,692 @@
+/*
+ * This file is subject to the terms and conditions of the GNU General Public
+ * License. See the file "COPYING" in the main directory of this archive
@@ -2789,8 +2789,6 @@
+ if (!is_2315())
+ return;
+
-+ gpio_request(AR2315_RESET_GPIO, "reset");
-+
+ /* Clear any lingering AHB errors */
+ config = read_c0_config();
+ write_c0_config(config & ~0x3);