summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-10-20 16:17:36 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-10-20 16:17:36 +0000
commit6585073a0400b93fa5c8d6a0982ae09a8e7f6d4c (patch)
treeb9e8bf3cad1f14829d6e073ef792f3eee60684f9
parent17c32c468550edf0282bb459445097bc023f02c2 (diff)
downloadmaster-31e0f0ae-6585073a0400b93fa5c8d6a0982ae09a8e7f6d4c.tar.gz
master-31e0f0ae-6585073a0400b93fa5c8d6a0982ae09a8e7f6d4c.tar.bz2
master-31e0f0ae-6585073a0400b93fa5c8d6a0982ae09a8e7f6d4c.zip
Add missing evaloader specific changes from #2830
SVN-Revision: 13018
-rw-r--r--target/linux/ar7/image/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/target/linux/ar7/image/Makefile b/target/linux/ar7/image/Makefile
index 170ad7a7a5..90f0d847b9 100644
--- a/target/linux/ar7/image/Makefile
+++ b/target/linux/ar7/image/Makefile
@@ -52,6 +52,10 @@ define align/jffs2-128k
bs=131072 conv=sync
endef
+define align/squashfs
+bs=65536 conv=sync
+endef
+
define Image/Build/CyberTAN
(dd if=/dev/zero bs=16 count=1; cat $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin) | \
$(STAGING_DIR_HOST)/bin/addpattern -p $(3) -o $(BIN_DIR)/openwrt-$(2)-$(4)-code.bin
@@ -65,9 +69,10 @@ endef
#endef
define Image/Build/EVA
- $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_ENTRY) $(KERNEL_ENTRY) $(KDIR)/vmlinux.lzma $(BIN_DIR)/openwrt-$(2)-$(1).bin
- cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(1).bin
- $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1).bin)
+ $(STAGING_DIR_HOST)/bin/lzma2eva $(EVA_LOADADDR) 0x$${shell $(TARGET_CROSS)nm $(KDIR)/linux-*/vmlinux | grep kernel_entry | cut -d' ' -f1} $(KDIR)/vmlinux.lzma $(KDIR)/loader.eva
+ dd if=$(KDIR)/loader.eva $(call align/$(1)) > $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
+ cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
+ $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin)
endef
define Image/Build