summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-03-15 11:03:38 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-03-15 11:03:38 +0000
commit5da6ae3ab513c86487fed935f85532dfed8ffdf9 (patch)
tree51c288047bc545c0601a7166b07afc993bd32428
parent704320385f3d3c2b9c38a78c8d1e6c0a7b91e6e3 (diff)
downloadmaster-31e0f0ae-5da6ae3ab513c86487fed935f85532dfed8ffdf9.tar.gz
master-31e0f0ae-5da6ae3ab513c86487fed935f85532dfed8ffdf9.tar.bz2
master-31e0f0ae-5da6ae3ab513c86487fed935f85532dfed8ffdf9.zip
ar71xx: create separated and smaller sysupgrade files for the DIR-615 and similar boards
SVN-Revision: 20230
-rw-r--r--target/linux/ar71xx/image/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 81ea68fe42..c5d79935bf 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -143,9 +143,13 @@ define Image/Build/Cameo
-d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
( \
dd if=$(KDIR)/vmlinux-$(2).uImage bs=896k conv=sync; \
+ dd if=$(KDIR)/root.$(1) \
+ ) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
+ ( \
+ dd if=$(KDIR)/vmlinux-$(2).uImage bs=896k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=2880k conv=sync; \
echo -n $(4); \
- ) > $(call imgname,$(1),$(2)).uni; \
+ ) > $(call imgname,$(1),$(2))-factory.bin; \
fi; fi
endef
@@ -163,9 +167,13 @@ define Image/Build/Cameo7240
-d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
( \
dd if=$(KDIR)/vmlinux-$(2).uImage bs=896k conv=sync; \
+ dd if=$(KDIR)/root.$(1) \
+ ) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
+ ( \
+ dd if=$(KDIR)/vmlinux-$(2).uImage bs=896k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=2752k conv=sync; \
echo -n $(4); \
- ) > $(call imgname,$(1),$(2))-universal.bin; \
+ ) > $(call imgname,$(1),$(2))-factory.bin; \
fi; fi
endef