summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-08-13 19:02:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-08-13 19:02:26 +0000
commit5b25a12e8fa741e4a63b081be1111a3194b86bf4 (patch)
tree1c790560e7d3c5ada9306503d06f29a1c8b6b9c3
parente69474719d5b3417cf3392c02c4a9fa6a0e464f4 (diff)
downloadmaster-31e0f0ae-5b25a12e8fa741e4a63b081be1111a3194b86bf4.tar.gz
master-31e0f0ae-5b25a12e8fa741e4a63b081be1111a3194b86bf4.tar.bz2
master-31e0f0ae-5b25a12e8fa741e4a63b081be1111a3194b86bf4.zip
image: fix handling of per-device kernel build commands
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46589
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 470a5dafeb..9dfce111a6 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -424,6 +424,7 @@ define Device/Build/kernel
_KERNEL_IMAGES += $(KDIR)/$$(KERNEL_NAME)
$(KDIR)/$$(KERNEL_NAME): image_prepare
$$(_TARGET): $$(if $$(KERNEL_INSTALL),$(BIN_DIR)/$$(KERNEL_IMAGE))
+ $(call Device/Export,$(KDIR)/$$(KERNEL_IMAGE),$(1))
$(BIN_DIR)/$$(KERNEL_IMAGE): $(KDIR)/$$(KERNEL_IMAGE)
cp $$^ $$@
ifndef IB
@@ -439,7 +440,6 @@ endef
define Device/Build/image
$$(_TARGET): $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2))
- $(eval $(call Device/Export,$(KDIR)/$(KERNEL_IMAGE),$(1)))
$(eval $(call Device/Export,$(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)),$(1)))
$(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)): $(KDIR)/$$(KERNEL_IMAGE) $(KDIR)/root.$(1)
@rm -f $$@