summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-22 12:45:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-22 12:45:07 +0000
commit54f5f6fa6c8aff9b2d9e1de626a8f5cd70de56fa (patch)
treeb63e132b308f263eb87266a2df76bedec7db70a4
parent9384cc59512c6974908289b67c3321d40ee4f19b (diff)
downloadmaster-31e0f0ae-54f5f6fa6c8aff9b2d9e1de626a8f5cd70de56fa.tar.gz
master-31e0f0ae-54f5f6fa6c8aff9b2d9e1de626a8f5cd70de56fa.tar.bz2
master-31e0f0ae-54f5f6fa6c8aff9b2d9e1de626a8f5cd70de56fa.zip
kernel: update to linux 4.1.3
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46437
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar71xx/patches-4.1/910-unaligned_access_hacks.patch2
-rw-r--r--target/linux/generic/patches-4.1/259-regmap_dynamic.patch2
-rw-r--r--target/linux/generic/patches-4.1/810-pci_disable_common_quirks.patch2
-rw-r--r--target/linux/generic/patches-4.1/921-use_preinit_as_init.patch2
5 files changed, 6 insertions, 6 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 3aac242079..e0b98267c6 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .18
LINUX_VERSION-4.0 = .8
-LINUX_VERSION-4.1 = .2
+LINUX_VERSION-4.1 = .3
LINUX_KERNEL_MD5SUM-3.18.18 = 6fce868a56f2d83f80cdad5fed457110
LINUX_KERNEL_MD5SUM-4.0.8 = a99375dd855de00635e9ac8e62b0f8e6
-LINUX_KERNEL_MD5SUM-4.1.2 = 26879db288cd9ffa17c9fd5db213b272
+LINUX_KERNEL_MD5SUM-4.1.3 = 96c2c77b1c54ba01cfd8fc2d13fbf828
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/ar71xx/patches-4.1/910-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-4.1/910-unaligned_access_hacks.patch
index 05f6465f37..3a73aea431 100644
--- a/target/linux/ar71xx/patches-4.1/910-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-4.1/910-unaligned_access_hacks.patch
@@ -332,7 +332,7 @@
IPSTATS_MIB_INHDRERRORS);
--- a/include/linux/types.h
+++ b/include/linux/types.h
-@@ -207,5 +207,11 @@ struct callback_head {
+@@ -215,5 +215,11 @@ struct callback_head {
/* clocksource cycle base type */
typedef u64 cycle_t;
diff --git a/target/linux/generic/patches-4.1/259-regmap_dynamic.patch b/target/linux/generic/patches-4.1/259-regmap_dynamic.patch
index 33ca2f65c9..def9ace7ff 100644
--- a/target/linux/generic/patches-4.1/259-regmap_dynamic.patch
+++ b/target/linux/generic/patches-4.1/259-regmap_dynamic.patch
@@ -78,7 +78,7 @@
#include <linux/mutex.h>
#include <linux/err.h>
#include <linux/of.h>
-@@ -2632,3 +2633,5 @@ static int __init regmap_initcall(void)
+@@ -2631,3 +2632,5 @@ static int __init regmap_initcall(void)
return 0;
}
postcore_initcall(regmap_initcall);
diff --git a/target/linux/generic/patches-4.1/810-pci_disable_common_quirks.patch b/target/linux/generic/patches-4.1/810-pci_disable_common_quirks.patch
index eee15517e0..8f72637eec 100644
--- a/target/linux/generic/patches-4.1/810-pci_disable_common_quirks.patch
+++ b/target/linux/generic/patches-4.1/810-pci_disable_common_quirks.patch
@@ -1,6 +1,6 @@
--- a/drivers/pci/Kconfig
+++ b/drivers/pci/Kconfig
-@@ -64,6 +64,12 @@ config XEN_PCIDEV_FRONTEND
+@@ -68,6 +68,12 @@ config XEN_PCIDEV_FRONTEND
The PCI device frontend driver allows the kernel to import arbitrary
PCI devices from a PCI backend to support PCI driver domains.
diff --git a/target/linux/generic/patches-4.1/921-use_preinit_as_init.patch b/target/linux/generic/patches-4.1/921-use_preinit_as_init.patch
index d3055354e2..73da5b3a54 100644
--- a/target/linux/generic/patches-4.1/921-use_preinit_as_init.patch
+++ b/target/linux/generic/patches-4.1/921-use_preinit_as_init.patch
@@ -1,6 +1,6 @@
--- a/init/main.c
+++ b/init/main.c
-@@ -959,7 +959,8 @@ static int __ref kernel_init(void *unuse
+@@ -960,7 +960,8 @@ static int __ref kernel_init(void *unuse
panic("Requested init %s failed (error %d).",
execute_command, ret);
}