summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 15:10:47 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 15:10:47 +0000
commit4e81a1473e0c7bc8620babb32ae6dc6418f1b13d (patch)
tree3d27241e6191d1c1db530080c96a7efd4705cf3e
parent960113fcfcc1c56d89c1df957ecf8d07ddecae08 (diff)
downloadmaster-31e0f0ae-4e81a1473e0c7bc8620babb32ae6dc6418f1b13d.tar.gz
master-31e0f0ae-4e81a1473e0c7bc8620babb32ae6dc6418f1b13d.tar.bz2
master-31e0f0ae-4e81a1473e0c7bc8620babb32ae6dc6418f1b13d.zip
brcm63xx: move gzip build command to include/image.mk
Allow other targets to make use of it. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46601
-rw-r--r--include/image.mk5
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile5
2 files changed, 5 insertions, 5 deletions
diff --git a/include/image.mk b/include/image.mk
index 56c60d6087..73fc805bb5 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -323,6 +323,11 @@ define Build/lzma
@mv $@.new $@
endef
+define Build/gzip
+ gzip -9n -c $@ $(1) > $@.new
+ @mv $@.new $@
+endef
+
define Build/kernel-bin
rm -f $@
cp $^ $@
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index f15b30b5f1..90b9fa68eb 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -38,11 +38,6 @@ define Build/append-dtb
cat $@.dtb >> $@
endef
-define Build/gzip
- gzip -9 -c $@ > $@.gz
- mv $@.gz $@
-endef
-
define Build/hcs-initramfs
$(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_bytes=$(HCS_MAGIC_BYTES) \
--rev_maj=$(HCS_REV_MAJ) --rev_min=$(HCS_REV_MIN) --input_file=$@ \