summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-03-16 12:25:06 +0000
committerNicolas Thill <nico@openwrt.org>2015-03-16 12:25:06 +0000
commit4b382a440b0a7cbddeddd5dafa24be7eca3cd628 (patch)
treed2220eee775ac541f4ba4df5a39f7104e9380018
parent81e51681e73490040842b96ac0250cde6c5a102a (diff)
downloadmaster-31e0f0ae-4b382a440b0a7cbddeddd5dafa24be7eca3cd628.tar.gz
master-31e0f0ae-4b382a440b0a7cbddeddd5dafa24be7eca3cd628.tar.bz2
master-31e0f0ae-4b382a440b0a7cbddeddd5dafa24be7eca3cd628.zip
packages: some (e)glibc fixes after r44701
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 44842
-rw-r--r--package/devel/perf/Makefile2
-rw-r--r--package/libs/libbsd/Makefile2
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/igmpproxy/Makefile2
-rw-r--r--package/network/services/lldpd/Makefile2
-rw-r--r--package/network/services/samba36/Makefile2
-rw-r--r--package/network/utils/iproute2/Makefile6
-rw-r--r--package/network/utils/iputils/Makefile2
-rw-r--r--package/system/fstools/Makefile4
-rw-r--r--package/system/procd/Makefile4
-rw-r--r--package/system/ubox/Makefile4
11 files changed, 15 insertions, 17 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index 3899b48d82..7cf504cedb 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/perf
SECTION:=devel
CATEGORY:=Development
- DEPENDS:= @USE_EGLIBC +libelf1 +libdw +libpthread +librt +binutils
+ DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
TITLE:=Linux performance monitoring tool
VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
URL:=http://www.kernel.org
diff --git a/package/libs/libbsd/Makefile b/package/libs/libbsd/Makefile
index 3c12d9f65b..fb38837e45 100644
--- a/package/libs/libbsd/Makefile
+++ b/package/libs/libbsd/Makefile
@@ -18,7 +18,7 @@ PKG_INSTALL:=1
define Package/libbsd
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=@USE_EGLIBC
+ DEPENDS:=@USE_GLIBC
TITLE:=common BSD library
endef
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index d1bbab86e7..eeba02802a 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -89,7 +89,7 @@ ifneq ($(LOCAL_TYPE),hostapd)
CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
endif
-ifdef CONFIG_USE_EGLIBC
+ifdef CONFIG_USE_GLIBC
TARGET_LDFLAGS += -lrt
TARGET_LDFLAGS_C += -lrt
endif
diff --git a/package/network/services/igmpproxy/Makefile b/package/network/services/igmpproxy/Makefile
index 33ed014040..03ad25819b 100644
--- a/package/network/services/igmpproxy/Makefile
+++ b/package/network/services/igmpproxy/Makefile
@@ -25,7 +25,7 @@ define Package/igmpproxy
SECTION:=net
CATEGORY:=Network
SUBMENU:=Routing and Redirection
- DEPENDS:=+USE_EGLIBC:librt
+ DEPENDS:=+USE_GLIBC:librt
TITLE:=Multicast Routing Daemon
URL:=http://sourceforge.net/projects/igmpproxy
endef
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 6f97f45e65..f038a340ac 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -31,7 +31,7 @@ define Package/lldpd
SUBMENU:=Routing and Redirection
TITLE:=Link Layer Discovery Protocol daemon
URL:=https://github.com/vincentbernat/lldpd/wiki
- DEPENDS:=+libevent2 +USE_EGLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
+ DEPENDS:=+libevent2 +USE_GLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
USERID:=lldp=121:lldp=129
MENU:=1
endef
diff --git a/package/network/services/samba36/Makefile b/package/network/services/samba36/Makefile
index d4c96d3854..70dfb2b16f 100644
--- a/package/network/services/samba36/Makefile
+++ b/package/network/services/samba36/Makefile
@@ -35,7 +35,7 @@ define Package/samba36-server
CATEGORY:=Network
TITLE:=Samba 3.6 SMB/CIFS server
URL:=http://www.samba.org/
- DEPENDS:=+USE_EGLIBC:librt
+ DEPENDS:=+USE_GLIBC:librt
endef
define Package/samba36-client
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 56d2897e2a..a2dae6d61b 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -82,10 +82,8 @@ define Build/Configure
> $(PKG_BUILD_DIR)/include/SNAPSHOT.h
endef
-ifdef CONFIG_USE_EGLIBC
- ifndef CONFIG_EGLIBC_VERSION_2_13
- TARGET_CFLAGS += -DHAVE_SETNS
- endif
+ifdef CONFIG_USE_GLIBC
+ TARGET_CFLAGS += -DHAVE_SETNS
endif
ifdef CONFIG_USE_MUSL
TARGET_CFLAGS += -DHAVE_SETNS
diff --git a/package/network/utils/iputils/Makefile b/package/network/utils/iputils/Makefile
index 1dc993cb81..8d7b84d6b5 100644
--- a/package/network/utils/iputils/Makefile
+++ b/package/network/utils/iputils/Makefile
@@ -68,7 +68,7 @@ endef
define Package/iputils-ping6
$(call Package/iputils/Default)
TITLE:=iputils - ping6
- DEPENDS+= @IPV6 +USE_EGLIBC:libopenssl
+ DEPENDS+= @IPV6 +USE_GLIBC:libopenssl
endef
define Package/iputils-ping6/description
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 054be0f43f..9040fd9417 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -30,13 +30,13 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
define Package/fstools
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubox +USE_EGLIBC:librt +NAND_SUPPORT:ubi-utils
+ DEPENDS:=+ubox +USE_GLIBC:librt +NAND_SUPPORT:ubi-utils
TITLE:=OpenWrt filesystem tools
MENU:=1
endef
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 02520606e8..6f9e6f8562 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -27,12 +27,12 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
define Package/procd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
+ DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_GLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
TITLE:=OpenWrt system process manager
endef
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index b58eb16b4d..5a51dc08dc 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -20,12 +20,12 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
define Package/ubox
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+libubox +ubusd +ubus +libubus +libuci +USE_EGLIBC:librt
+ DEPENDS:=+libubox +ubusd +ubus +libubus +libuci +USE_GLIBC:librt
TITLE:=OpenWrt system helper toolbox
endef