summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-12-10 15:20:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-12-10 15:20:44 +0000
commit48dcb640d8f06f1712837623ad11a3e8bf3858d6 (patch)
tree6e0de73b6d9003e980d1775156da0532def964ca
parentd9c68341ef4756ba15fd7e5c4b00ebbcc488df7c (diff)
downloadmaster-31e0f0ae-48dcb640d8f06f1712837623ad11a3e8bf3858d6.tar.gz
master-31e0f0ae-48dcb640d8f06f1712837623ad11a3e8bf3858d6.tar.bz2
master-31e0f0ae-48dcb640d8f06f1712837623ad11a3e8bf3858d6.zip
make $(STAGING_DIR)/host/share/aclocal a symlink to $(STAGING_DIR_HOST)/share/aclocal
SVN-Revision: 24422
-rw-r--r--tools/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 9306601c7a..4a39663cdb 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -61,8 +61,11 @@ define PrepareStaging
endef
# preparatory work
-$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
$(call PrepareStaging,$(STAGING_DIR))
+ mkdir -p $(STAGING_DIR)/host/share
+ rm -rf $(STAGING_DIR)/host/share/aclocal
+ ln -s $(STAGING_DIR_HOST)/share/aclocal $(STAGING_DIR)/host/share/
mkdir -p $(BUILD_DIR)/stamp
touch $@