summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-03-01 11:50:05 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-03-01 11:50:05 +0000
commit48d81f60743995bdc67ade4b4520fffdbae0c689 (patch)
tree051d2db18347c082f4a54f00b76d98b6fbf03991
parent578d9696e5d37b5a2bfb2dabfd021ac97d6b4be7 (diff)
downloadmaster-31e0f0ae-48d81f60743995bdc67ade4b4520fffdbae0c689.tar.gz
master-31e0f0ae-48d81f60743995bdc67ade4b4520fffdbae0c689.tar.bz2
master-31e0f0ae-48d81f60743995bdc67ade4b4520fffdbae0c689.zip
build firmware image for the Atlantis-Land A02-RB-W300N
SVN-Revision: 14711
-rw-r--r--target/linux/ar71xx/image/Makefile5
-rw-r--r--target/linux/ar71xx/profiles/atlantis.mk17
2 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index e32a197825..fabe8de0b0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -166,6 +166,10 @@ define Image/Build/Profile/TEW652BRP
$(call Image/Build/Template/AP81/$(1),tew-652brp,board=TEW-632BRP,"AP81-AR9130-RT-080609-05")
endef
+define Image/Build/Profile/A02RBW300N
+ $(call Image/Build/Template/AP81/$(1),a02-rb-w300n,board=TEW-632BRP,"AP81-AR9130-RT-070614-03")
+endef
+
define Image/Build/Profile/UBNTRS
$(call Image/Build/Template/UBNT/$(1),rs,board=UBNT-RS,RS,RSx)
endef
@@ -179,6 +183,7 @@ define Image/Build/Profile/TLWR941NDV2
endef
define Image/Build/Profile/Default
+ $(call Image/Build/Profile/A02RBW300N,$(1))
$(call Image/Build/Profile/DIR615C1,$(1))
$(call Image/Build/Profile/MZKW04NU,$(1))
$(call Image/Build/Profile/TEW632BRP,$(1))
diff --git a/target/linux/ar71xx/profiles/atlantis.mk b/target/linux/ar71xx/profiles/atlantis.mk
new file mode 100644
index 0000000000..c756bdd129
--- /dev/null
+++ b/target/linux/ar71xx/profiles/atlantis.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/A02RBW300N
+ NAME:=Atlantis-Land A02-RB-W300N
+ PACKAGES:=kmod-ath9k hostapd-mini
+endef
+
+define Profile/A02RBW300N/Description
+ Package set optimized for the Atlantis-Land A02-RB-W300N.
+endef
+
+$(eval $(call Profile,A02RBW300N))