summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-04-23 16:10:25 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-04-23 16:10:25 +0000
commit42c190ead8b626d4d74ff99b95fc08f361aaf5ee (patch)
tree11ed5f59e6947585f4d90c4e5344cd248b50aaa6
parent34f4f4a0c553ff15a9df1d71198a035d725abf74 (diff)
downloadmaster-31e0f0ae-42c190ead8b626d4d74ff99b95fc08f361aaf5ee.tar.gz
master-31e0f0ae-42c190ead8b626d4d74ff99b95fc08f361aaf5ee.tar.bz2
master-31e0f0ae-42c190ead8b626d4d74ff99b95fc08f361aaf5ee.zip
ensure that profile Makefiles are sourced in alphabetical order Since make 3.82 does not guarantee file ordering anymore, target profiles might get included in random order, leading to bad default values when only selecting the toplevel target and populating the .config with defconfig. This commit should also fix the ar71xx snapshot builds.
SVN-Revision: 31449
-rw-r--r--include/target.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/target.mk b/include/target.mk
index 097b275cf2..e5166fb784 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -84,12 +84,12 @@ endif
ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
define IncludeProfiles
- -include $(PLATFORM_DIR)/profiles/*.mk
- -include $(PLATFORM_SUBDIR)/profiles/*.mk
+ -include $(sort $(wildcard $(PLATFORM_DIR)/profiles/*.mk))
+ -include $(sort $(wildcard $(PLATFORM_SUBDIR)/profiles/*.mk))
endef
else
define IncludeProfiles
- -include $(PLATFORM_DIR)/profiles/*.mk
+ -include $(sort $(wildcard $(PLATFORM_DIR)/profiles/*.mk))
endef
endif