summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-17 09:29:34 +0000
committerJohn Crispin <john@openwrt.org>2015-12-17 09:29:34 +0000
commit429ab0113a71841ab5c3c181af6bc3d585743dc6 (patch)
tree04ce8cb1a549a1b93e6dda48a1eef864a282993a
parentd4b8d51580f61bc242b3a51566d2e4afd1f4a150 (diff)
downloadmaster-31e0f0ae-429ab0113a71841ab5c3c181af6bc3d585743dc6.tar.gz
master-31e0f0ae-429ab0113a71841ab5c3c181af6bc3d585743dc6.tar.bz2
master-31e0f0ae-429ab0113a71841ab5c3c181af6bc3d585743dc6.zip
kernel: kmod-ptp selects a new config symbol
since Kernel 3.14 408eccce net: ptp: move PTP classifier in its own file found while bug search thx olmari on IRC Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 47923
-rw-r--r--package/kernel/linux/modules/other.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 9bb9dec2bc..62fdc3cd69 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -820,7 +820,9 @@ define KernelPackage/ptp
SUBMENU:=$(OTHER_MENU)
TITLE:=PTP clock support
DEPENDS:=+kmod-pps
- KCONFIG:=CONFIG_PTP_1588_CLOCK
+ KCONFIG:= \
+ CONFIG_PTP_1588_CLOCK \
+ CONFIG_NET_PTP_CLASSIFY=y
FILES:=$(LINUX_DIR)/drivers/ptp/ptp.ko
AUTOLOAD:=$(call AutoLoad,18,ptp,1)
endef