summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-31 23:29:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-31 23:29:41 +0000
commit411515b368f2addeac614ebae8a8fea6c80d907b (patch)
tree237c7b4741167a202cc1862a33bef54b09db1ea5
parent6a42ee65173b29f04602bbcf4ad3da5f0d16cc6b (diff)
downloadmaster-31e0f0ae-411515b368f2addeac614ebae8a8fea6c80d907b.tar.gz
master-31e0f0ae-411515b368f2addeac614ebae8a8fea6c80d907b.tar.bz2
master-31e0f0ae-411515b368f2addeac614ebae8a8fea6c80d907b.zip
ar71xx/image: use SOURCE_DATE_EPOCH for mksquashfs-lzma
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 48589
-rw-r--r--target/linux/ar71xx/image/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 080d9606a2..5768cbd97b 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -22,7 +22,9 @@ define Build/netgear-squashfs
cp $@ $@.fs/image/uImage
$(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
$@.fs $@.squashfs \
- -noappend -root-owned -be -b 65536
+ -noappend -root-owned -be -b 65536 \
+ $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
+
dd if=/dev/zero bs=1k count=1 >> $@.squashfs
mkimage \
-A mips -O linux -T filesystem -C none \
@@ -2064,7 +2066,8 @@ define Image/Build/Netgear/buildkernel
cat $(KDIR_TMP)/vmlinux-$(2).uImage > $(KDIR_TMP)/$(2)/image/uImage
$(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
$(KDIR_TMP)/$(2) $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp1 \
- -noappend -root-owned -be -b 65536
+ -noappend -root-owned -be -b 65536 \
+ $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
( \
cat $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp1; \
dd if=/dev/zero bs=1k count=1 \