summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-12-02 20:32:11 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-12-02 20:32:11 +0000
commit40a09b93d274737c704165f687149b4956fbd45c (patch)
tree69f6fdae0eb58c698516a4b1cafc0bf918c77ac2
parentc4ea02cc699bf8758a913b9e5a650a305e7fc9c4 (diff)
downloadmaster-31e0f0ae-40a09b93d274737c704165f687149b4956fbd45c.tar.gz
master-31e0f0ae-40a09b93d274737c704165f687149b4956fbd45c.tar.bz2
master-31e0f0ae-40a09b93d274737c704165f687149b4956fbd45c.zip
mac80211: install new firmware for ath9k-htc on target
For quite some time new firmware for ath9k-htc devices is available in http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/tree/ath9k_htc/ Moreover ath9k-htc kernel driver expects this new v1.4 firmware to exist in /lib/firmware/ath9k_htc. What happens currently: ---------------------------->8-------------------------- [ 7.830000] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested [ 7.840000] usb 1-1: Direct firmware load for ath9k_htc/htc_9271-1.4.0.fw failed with error -2 [ 7.850000] usb 1-1: Falling back to user helper [ 7.870000] usbcore: registered new interface driver ath9k_htc [ 7.880000] firmware ath9k_htc!htc_9271-1.4.0.fw: firmware_loading_store: map pages failed [ 7.890000] usb 1-1: ath9k_htc: Firmware htc_9271.fw requested [ 8.200000] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 50980 [ 8.440000] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits [ 10.720000] ath9k_htc 1-1:1.0: ath9k_htc: FW Version: 1.3 [ 10.740000] ath9k_htc 1-1:1.0: FW RMW support: Off [ 10.760000] ieee80211 phy0: Atheros AR9271 Rev:1 ---------------------------->8-------------------------- And with that patch new firmware is used instead: ---------------------------->8-------------------------- [ 33.920000] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested [ 34.230000] usb 1-1: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008 [ 34.480000] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits [ 34.740000] ath9k_htc 1-1:1.0: ath9k_htc: FW Version: 1.4 [ 34.750000] ath9k_htc 1-1:1.0: FW RMW support: On ---------------------------->8-------------------------- Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47693
-rw-r--r--package/kernel/mac80211/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 4b4f774c40..1dd1b84e7f 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1823,11 +1823,11 @@ endef
define KernelPackage/ath9k-htc/install
- $(INSTALL_DIR) $(1)/lib/firmware
+ $(INSTALL_DIR) $(1)/lib/firmware/ath9k_htc
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/htc_9271.fw \
- $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/htc_7010.fw \
- $(1)/lib/firmware/
+ $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/ath9k_htc/htc_9271-1.4.0.fw \
+ $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/ath9k_htc/htc_7010-1.4.0.fw \
+ $(1)/lib/firmware/ath9k_htc
endef
define KernelPackage/b43/install