summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-15 13:40:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-15 13:40:35 +0000
commit3ca7f3bd6f53c36530693696670a182208b0925c (patch)
tree82045268d4433857ba27c34fabcb48a00851469c
parentaa59a08b45f29fa21bda8fcbc2f159047f6034ce (diff)
downloadmaster-31e0f0ae-3ca7f3bd6f53c36530693696670a182208b0925c.tar.gz
master-31e0f0ae-3ca7f3bd6f53c36530693696670a182208b0925c.tar.bz2
master-31e0f0ae-3ca7f3bd6f53c36530693696670a182208b0925c.zip
update to 2.6.27.11
SVN-Revision: 14043
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/au1000/Makefile2
-rw-r--r--target/linux/au1000/patches-2.6.27/007-gpiolib.patch17
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/ifxmips/Makefile2
-rw-r--r--target/linux/olpc/Makefile2
-rw-r--r--target/linux/ppc40x/Makefile2
-rw-r--r--target/linux/ppc44x/Makefile2
-rw-r--r--target/linux/x86/Makefile2
10 files changed, 17 insertions, 20 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index f481588162..78e8ef4989 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -28,8 +28,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.26.8)
LINUX_KERNEL_MD5SUM:=05dd0d4f8f110b4219ae6ec7a36c046d
endif
-ifeq ($(LINUX_VERSION),2.6.27.10)
- LINUX_KERNEL_MD5SUM:=ef06a3ea963f556948e77971df912303
+ifeq ($(LINUX_VERSION),2.6.27.11)
+ LINUX_KERNEL_MD5SUM:=29bf3e01673b42f7bf993aa8295b8245
endif
ifeq ($(LINUX_VERSION),2.6.28)
LINUX_KERNEL_MD5SUM:=d351e44709c9810b85e29b877f50968a
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 7c1d44f9b5..b7aa42cfd5 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=ar71xx
BOARDNAME:=Atheros AR71xx
FEATURES:=squashfs tgz
-LINUX_VERSION:=2.6.27.10
+LINUX_VERSION:=2.6.27.11
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index ed31eb70d9..6c49ee89f9 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -11,7 +11,7 @@ BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci
-LINUX_VERSION:=2.6.27.10
+LINUX_VERSION:=2.6.27.11
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += hostapd-mini yamonenv
diff --git a/target/linux/au1000/patches-2.6.27/007-gpiolib.patch b/target/linux/au1000/patches-2.6.27/007-gpiolib.patch
index 1cd73d7dcf..650c99796d 100644
--- a/target/linux/au1000/patches-2.6.27/007-gpiolib.patch
+++ b/target/linux/au1000/patches-2.6.27/007-gpiolib.patch
@@ -1,14 +1,12 @@
-diff -urN linux-2.6.27.7/arch/mips/au1000/Kconfig linux-2.6.27.7.new/arch/mips/au1000/Kconfig
---- linux-2.6.27.7/arch/mips/au1000/Kconfig 2008-11-21 00:02:37.000000000 +0100
-+++ linux-2.6.27.7.new/arch/mips/au1000/Kconfig 2008-12-08 11:44:09.000000000 +0100
-@@ -134,3 +134,4 @@
+--- a/arch/mips/au1000/Kconfig
++++ b/arch/mips/au1000/Kconfig
+@@ -134,3 +134,4 @@ config SOC_AU1X00
select SYS_HAS_CPU_MIPS32_R1
select SYS_SUPPORTS_32BIT_KERNEL
select SYS_SUPPORTS_APM_EMULATION
+ select ARCH_REQUIRE_GPIOLIB
-diff -urN linux-2.6.27.7/arch/mips/au1000/common/gpio.c linux-2.6.27.7.new/arch/mips/au1000/common/gpio.c
---- linux-2.6.27.7/arch/mips/au1000/common/gpio.c 2008-11-21 00:02:37.000000000 +0100
-+++ linux-2.6.27.7.new/arch/mips/au1000/common/gpio.c 2008-12-08 11:58:30.000000000 +0100
+--- a/arch/mips/au1000/common/gpio.c
++++ b/arch/mips/au1000/common/gpio.c
@@ -1,5 +1,5 @@
/*
- * Copyright (C) 2007, OpenWrt.org, Florian Fainelli <florian@openwrt.org>
@@ -312,9 +310,8 @@ diff -urN linux-2.6.27.7/arch/mips/au1000/common/gpio.c linux-2.6.27.7.new/arch/
}
-EXPORT_SYMBOL(au1xxx_gpio_direction_output);
+arch_initcall(au1000_gpio_init);
-diff -urN linux-2.6.27.7/include/asm-mips/mach-au1x00/gpio.h linux-2.6.27.7.new/include/asm-mips/mach-au1x00/gpio.h
---- linux-2.6.27.7/include/asm-mips/mach-au1x00/gpio.h 2008-11-21 00:02:37.000000000 +0100
-+++ linux-2.6.27.7.new/include/asm-mips/mach-au1x00/gpio.h 2008-12-08 11:43:37.000000000 +0100
+--- a/include/asm-mips/mach-au1x00/gpio.h
++++ b/include/asm-mips/mach-au1x00/gpio.h
@@ -1,69 +1,21 @@
#ifndef _AU1XXX_GPIO_H_
#define _AU1XXX_GPIO_H_
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index eecfd9bcff..d2612cf82a 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm
-LINUX_VERSION:=2.6.27.10
+LINUX_VERSION:=2.6.27.11
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ifxmips/Makefile b/target/linux/ifxmips/Makefile
index e590eee092..3328960243 100644
--- a/target/linux/ifxmips/Makefile
+++ b/target/linux/ifxmips/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Infineon Mips
FEATURES:=squashfs jffs2
SUBTARGETS:=generic nfs
LINUX_VERSION:=2.6.26.8
-#LINUX_VERSION:=2.6.27.10
+#LINUX_VERSION:=2.6.27.11
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
diff --git a/target/linux/olpc/Makefile b/target/linux/olpc/Makefile
index 1cb620c261..2a4fb0649b 100644
--- a/target/linux/olpc/Makefile
+++ b/target/linux/olpc/Makefile
@@ -11,7 +11,7 @@ BOARD:=olpc
BOARDNAME:=OLPC XO-1
FEATURES:=squashfs ext2
-LINUX_VERSION:=2.6.27.10
+LINUX_VERSION:=2.6.27.11
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index 98cb277afe..b83439d598 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -11,7 +11,7 @@ BOARD:=ppc40x
BOARDNAME:=AMCC/IBM PPC40x
FEATURES:=squashfs
-LINUX_VERSION:=2.6.27.10
+LINUX_VERSION:=2.6.27.11
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index d9ea661c41..deed81e6d7 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -11,7 +11,7 @@ BOARD:=ppc44x
BOARDNAME:=AMCC/IBM PPC44x
FEATURES:=squashfs
-LINUX_VERSION:=2.6.27.10
+LINUX_VERSION:=2.6.27.11
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 79710722d3..1f76348032 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi vmdk
SUBTARGETS=generic
-LINUX_VERSION:=2.6.27.10
+LINUX_VERSION:=2.6.27.11
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci