summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-09-06 17:26:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-09-06 17:26:37 +0000
commit3b61c2c2b161f082bc2ff06a6666f1d32bed667f (patch)
tree55a32c1512b2ee2ada65fe9fa85150eb5b93eb5b
parent27915ac778c7b142a5fe9a8db977e2d89706d3f2 (diff)
downloadmaster-31e0f0ae-3b61c2c2b161f082bc2ff06a6666f1d32bed667f.tar.gz
master-31e0f0ae-3b61c2c2b161f082bc2ff06a6666f1d32bed667f.tar.bz2
master-31e0f0ae-3b61c2c2b161f082bc2ff06a6666f1d32bed667f.zip
now that $(BOARD) is part of the opkg ARCH, there's no reason to keep the board name around in kmod-* package versions anymore
SVN-Revision: 17528
-rw-r--r--include/kernel.mk4
-rw-r--r--package/kernel/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index cb62e63810..9e64316024 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -109,8 +109,8 @@ define KernelPackage
SECTION:=kernel
CATEGORY:=Kernel modules
DESCRIPTION:=$(DESCRIPTION)
- EXTRA_DEPENDS:=kernel (=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))
- VERSION:=$(LINUX_VERSION)$(if $(PKG_VERSION),+$(PKG_VERSION))-$(BOARD)-$(if $(PKG_RELEASE),$(PKG_RELEASE),$(LINUX_RELEASE))
+ EXTRA_DEPENDS:=kernel (=$(LINUX_VERSION)-$(LINUX_RELEASE))
+ VERSION:=$(LINUX_VERSION)$(if $(PKG_VERSION),+$(PKG_VERSION))-$(if $(PKG_RELEASE),$(PKG_RELEASE),$(LINUX_RELEASE))
$(call KernelPackage/$(1))
$(call KernelPackage/$(1)/$(KERNEL))
$(call KernelPackage/$(1)/$(BOARD)-$(KERNEL))
diff --git a/package/kernel/Makefile b/package/kernel/Makefile
index cde30683c3..75925df550 100644
--- a/package/kernel/Makefile
+++ b/package/kernel/Makefile
@@ -34,7 +34,7 @@ define Package/kernel
CATEGORY:=Kernel
DEFAULT:=y
TITLE:=Virtual kernel package
- VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
+ VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)
endef
define Package/kernel/install