summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-02-01 15:31:23 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-02-01 15:31:23 +0000
commit3310df6b521c25898d7db6dcdf49b13eebd982a3 (patch)
tree1dfc48078d1326a1b1f73780cce78a6fa8d18f7c
parent1ef07eee4ab65e70bb9f8d896d1678891ce83ddf (diff)
downloadmaster-31e0f0ae-3310df6b521c25898d7db6dcdf49b13eebd982a3.tar.gz
master-31e0f0ae-3310df6b521c25898d7db6dcdf49b13eebd982a3.tar.bz2
master-31e0f0ae-3310df6b521c25898d7db6dcdf49b13eebd982a3.zip
alix2: correct h/w configuration Bump to version 3.2. Simplify and correct kernel config (based on x86/config-3.2). Drop obsolete CS5535 GPIO driver.
[Patch from Philipp Prindeville, via http://patchwork.openwrt.org/patch/1804/] SVN-Revision: 29981
-rw-r--r--target/linux/x86/alix2/config-default28
-rw-r--r--target/linux/x86/alix2/target.mk8
2 files changed, 20 insertions, 16 deletions
diff --git a/target/linux/x86/alix2/config-default b/target/linux/x86/alix2/config-default
index 4cad672115..def5482ad3 100644
--- a/target/linux/x86/alix2/config-default
+++ b/target/linux/x86/alix2/config-default
@@ -1,24 +1,28 @@
-CONFIG_PROCESSOR_SELECT=y
-CONFIG_CPU_SUP_AMD=y
-CONFIG_GPIOLIB=y
-CONFIG_GPIO_SYSFS=y
+CONFIG_ALIX=y
+# CONFIG_AMD_NB is not set
+CONFIG_DMI=y
+CONFIG_DMIID=y
+# CONFIG_DMI_SYSFS is not set
CONFIG_DEBUG_BUGVERBOSE=y
-CONFIG_HAVE_PERF_EVENTS=y
+# CONFIG_FB_GEODE is not set
CONFIG_GENERIC_GPIO=y
+CONFIG_GPIOLIB=y
+CONFIG_GPIO_SYSFS=y
+# CONFIG_HIGHMEM64G is not set
CONFIG_HWMON=y
# CONFIG_HWMON_DEBUG_CHIP is not set
# CONFIG_M486 is not set
+# CONFIG_MATH_EMULATION is not set
CONFIG_MGEODE_LX=y
-# CONFIG_MOUSE_PS2 is not set
+CONFIG_PATA_CS5536=y
# CONFIG_PCIEPORTBUS is not set
CONFIG_PCSPKR_PLATFORM=y
+# CONFIG_POWER_SUPPLY is not set
# CONFIG_SCx200 is not set
# CONFIG_SERIO_I8042 is not set
# CONFIG_SERIO_LIBPS2 is not set
+# CONFIG_SERIO_SERPORT is not set
+CONFIG_THERMAL_HWMON=y
+# CONFIG_SENSORS_K10TEMP is not set
+# CONFIG_SENSORS_VIA_CPUTEMP is not set
CONFIG_X86_DEBUGCTLMSR=y
-# CONFIG_X86_GENERIC is not set
-CONFIG_X86_INTERNODE_CACHE_SHIFT=5
-CONFIG_X86_L1_CACHE_SHIFT=5
-# CONFIG_CS5535_CLOCK_EVENT_SRC is not set
-CONFIG_PATA_CS5536=y
-CONFIG_ALIX=y
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
index cece30e173..d9f08f6dba 100644
--- a/target/linux/x86/alix2/target.mk
+++ b/target/linux/x86/alix2/target.mk
@@ -1,9 +1,9 @@
+LINUX_VERSION:=3.2.1
BOARDNAME:=PCEngines alix2
FEATURES:=squashfs jffs2 ext4 pci usb gpio
-ALIX2_GPIO = $(if $(findstring 2.6.32,$(LINUX_VERSION)),gpio-cs5535,gpio-cs5535-new)
DEFAULT_PACKAGES += \
kmod-crypto-hw-geode kmod-crypto-ocf \
- kmod-$(ALIX2_GPIO) kmod-gpio-nsc \
+ kmod-gpio-cs5535-new kmod-gpio-nsc \
kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
kmod-cs5536 \
kmod-hwmon-core kmod-hwmon-lm90 \
@@ -32,6 +32,6 @@ define Target/Description
Build firmware images for PCEngines alix2 board
endef
-define KernelPackage/$(ALIX2_GPIO)/install
- sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-$(ALIX2_GPIO)
+define KernelPackage/gpio-cs5535-new/install
+ sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535-new
endef