summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-02-19 12:44:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-02-19 12:44:16 +0000
commit31709b2c76c851f343f258e08c686b50aaa31be1 (patch)
treea4bad9c62495229738fef39c9ae135de083add15
parent45c9f5e75ea5fe5e01f735bf7cb75dac7d654211 (diff)
downloadmaster-31e0f0ae-31709b2c76c851f343f258e08c686b50aaa31be1.tar.gz
master-31e0f0ae-31709b2c76c851f343f258e08c686b50aaa31be1.tar.bz2
master-31e0f0ae-31709b2c76c851f343f258e08c686b50aaa31be1.zip
update to 2.6.35.11
SVN-Revision: 25582
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/at91/Makefile2
-rw-r--r--target/linux/au1000/Makefile2
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/generic/patches-2.6.35/040-arm-update-mach-types.patch2
-rw-r--r--target/linux/generic/patches-2.6.35/240-packet_socket_type.patch4
-rw-r--r--target/linux/generic/patches-2.6.35/801-usb_serial_endpoint_size.patch6
-rw-r--r--target/linux/generic/patches-2.6.35/980-vm_exports.patch6
-rw-r--r--target/linux/kirkwood/Makefile2
-rw-r--r--target/linux/lantiq/Makefile2
10 files changed, 16 insertions, 16 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 7e0eee1350..b7707d3322 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -14,8 +14,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.34.7)
LINUX_KERNEL_MD5SUM:=8964e26120e84844998a673464a980ea
endif
-ifeq ($(LINUX_VERSION),2.6.35.9)
- LINUX_KERNEL_MD5SUM:=18d339e9229560e73c4249dffdc3fd90
+ifeq ($(LINUX_VERSION),2.6.35.11)
+ LINUX_KERNEL_MD5SUM:=4c9ee33801f5ad0f4d5e615fac66d535
endif
ifeq ($(LINUX_VERSION),2.6.36.4)
LINUX_KERNEL_MD5SUM:=c05dd941d0e249695e9f72568888e1bf
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index d06bb842e3..0ef55e6410 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -14,7 +14,7 @@ FEATURES:=squashfs jffs2 targz
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
SUBTARGETS:=netus tqma9263
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.35.11
DEVICE_TYPE=
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index b2b1341793..a30f6b65ef 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci
SUBTARGETS=au1500 au1550
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.35.11
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini yamonenv
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index 81e30f3a15..e5e2d55dd3 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.35.11
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/generic/patches-2.6.35/040-arm-update-mach-types.patch b/target/linux/generic/patches-2.6.35/040-arm-update-mach-types.patch
index c00886e593..014bb256a4 100644
--- a/target/linux/generic/patches-2.6.35/040-arm-update-mach-types.patch
+++ b/target/linux/generic/patches-2.6.35/040-arm-update-mach-types.patch
@@ -81,7 +81,7 @@
htc_excalibur_s620 MACH_HTC_EXCALIBUR_S620 HTC_EXCALIBUR_S620 2391
htc_opal MACH_HTC_OPAL HTC_OPAL 2392
touchbook MACH_TOUCHBOOK TOUCHBOOK 2393
-@@ -2446,7 +2446,7 @@ siogentoo1 MACH_SIOGENTOO1 SIOGENTOO1
+@@ -2446,7 +2446,7 @@ siogentoo1 MACH_SIOGENTOO1 SIOGENTOO1
siogentoo2 MACH_SIOGENTOO2 SIOGENTOO2 2459
sm3k MACH_SM3K SM3K 2460
acer_tempo_f900 MACH_ACER_TEMPO_F900 ACER_TEMPO_F900 2461
diff --git a/target/linux/generic/patches-2.6.35/240-packet_socket_type.patch b/target/linux/generic/patches-2.6.35/240-packet_socket_type.patch
index 44117659a4..7093031b1c 100644
--- a/target/linux/generic/patches-2.6.35/240-packet_socket_type.patch
+++ b/target/linux/generic/patches-2.6.35/240-packet_socket_type.patch
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
-@@ -2027,6 +2031,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -2030,6 +2034,16 @@ packet_setsockopt(struct socket *sock, i
po->has_vnet_hdr = !!val;
return 0;
}
@@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
default:
return -ENOPROTOOPT;
}
-@@ -2084,6 +2098,13 @@ static int packet_getsockopt(struct sock
+@@ -2087,6 +2101,13 @@ static int packet_getsockopt(struct sock
data = &val;
break;
diff --git a/target/linux/generic/patches-2.6.35/801-usb_serial_endpoint_size.patch b/target/linux/generic/patches-2.6.35/801-usb_serial_endpoint_size.patch
index cfbcbe88fb..735c4e355b 100644
--- a/target/linux/generic/patches-2.6.35/801-usb_serial_endpoint_size.patch
+++ b/target/linux/generic/patches-2.6.35/801-usb_serial_endpoint_size.patch
@@ -1,6 +1,6 @@
--- a/drivers/usb/serial/usb-serial.c
+++ b/drivers/usb/serial/usb-serial.c
-@@ -61,6 +61,7 @@ static struct usb_driver usb_serial_driv
+@@ -62,6 +62,7 @@ static struct usb_driver usb_serial_driv
drivers depend on it.
*/
@@ -8,7 +8,7 @@
static int debug;
/* initially all NULL */
static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
-@@ -912,7 +913,7 @@ int usb_serial_probe(struct usb_interfac
+@@ -913,7 +914,7 @@ int usb_serial_probe(struct usb_interfac
}
buffer_size = serial->type->bulk_in_size;
if (!buffer_size)
@@ -17,7 +17,7 @@
port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1382,3 +1383,5 @@ MODULE_LICENSE("GPL");
+@@ -1385,3 +1386,5 @@ MODULE_LICENSE("GPL");
module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not");
diff --git a/target/linux/generic/patches-2.6.35/980-vm_exports.patch b/target/linux/generic/patches-2.6.35/980-vm_exports.patch
index 5ca94b25a2..169bf43010 100644
--- a/target/linux/generic/patches-2.6.35/980-vm_exports.patch
+++ b/target/linux/generic/patches-2.6.35/980-vm_exports.patch
@@ -48,7 +48,7 @@
{
--- a/kernel/exit.c
+++ b/kernel/exit.c
-@@ -506,6 +506,7 @@ struct files_struct *get_files_struct(st
+@@ -514,6 +514,7 @@ struct files_struct *get_files_struct(st
return files;
}
@@ -56,7 +56,7 @@
void put_files_struct(struct files_struct *files)
{
-@@ -527,6 +528,7 @@ void put_files_struct(struct files_struc
+@@ -535,6 +536,7 @@ void put_files_struct(struct files_struc
rcu_read_unlock();
}
}
@@ -76,7 +76,7 @@
* macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c
+++ b/kernel/sched.c
-@@ -4262,6 +4262,7 @@ int can_nice(const struct task_struct *p
+@@ -4390,6 +4390,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
capable(CAP_SYS_NICE));
}
diff --git a/target/linux/kirkwood/Makefile b/target/linux/kirkwood/Makefile
index 1dbd5b1450..101cea3b74 100644
--- a/target/linux/kirkwood/Makefile
+++ b/target/linux/kirkwood/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Marvell Kirkwood
FEATURES:=targz usb jffs2
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.35.11
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 5afe5662da..309b31a164 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
FEATURES:=squashfs jffs2 atm
SUBTARGETS:=xway
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.35.11
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time