summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-25 16:12:52 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-25 16:12:52 +0000
commit2d523f7d59ef1ccf2ba7bc00f7347a43ba40d73e (patch)
tree065a9dd05e8b0f1ccc6b4f838d526baae7e88222
parent08dad3f4293b9d596ad5f61b1b07d893f63fbd18 (diff)
downloadmaster-31e0f0ae-2d523f7d59ef1ccf2ba7bc00f7347a43ba40d73e.tar.gz
master-31e0f0ae-2d523f7d59ef1ccf2ba7bc00f7347a43ba40d73e.tar.bz2
master-31e0f0ae-2d523f7d59ef1ccf2ba7bc00f7347a43ba40d73e.zip
procd: make build of upgraded optional
Update to latest git head in order to support disabling the build of upgraded which causes linker errors on avr32. This also adds some fixes to the ubus system.info and system.board methods. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44134
-rw-r--r--package/system/procd/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index bfb0e002fd..4f8b2d375c 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2015-01-09
+PKG_VERSION:=2015-01-25
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=e10fca6b88a8b57fe5a9e80dfd941ae6d98cb970
+PKG_SOURCE_VERSION:=7e6045fe4558e442e97e4a8967f08689d53f2cc4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -68,6 +68,10 @@ endef
PKG_CONFIG_DEPENDS:= PROCD_SHOW_BOOT PROCD_ZRAM_TMPFS
+ifeq ($(CONFIG_NAND_SUPPORT),y)
+ CMAKE_OPTIONS += -DBUILD_UPGRADED=1
+endif
+
ifeq ($(CONFIG_PROCD_SHOW_BOOT),y)
CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE=1
endif