summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-06-07 20:07:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-06-07 20:07:32 +0000
commit2cda2ff5752de60b39ced1e445364f76f5c13bdd (patch)
treec956b82d62e66737711cc34e344f6a1ca7d50507
parent2b67efae7c80c4b604420a2364648e46b0d5b407 (diff)
downloadmaster-31e0f0ae-2cda2ff5752de60b39ced1e445364f76f5c13bdd.tar.gz
master-31e0f0ae-2cda2ff5752de60b39ced1e445364f76f5c13bdd.tar.bz2
master-31e0f0ae-2cda2ff5752de60b39ced1e445364f76f5c13bdd.zip
create jffs2 images
SVN-Revision: 16374
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/image/Makefile18
2 files changed, 18 insertions, 2 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 8c44daf47e..5948e825c8 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=mips
BOARD:=ar71xx
BOARDNAME:=Atheros AR71xx/AR913x
-FEATURES:=squashfs tgz
+FEATURES:=squashfs jffs2 tgz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
LINUX_VERSION:=2.6.28.10
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 02efef03b5..e1b36c209f 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -119,7 +119,7 @@ define Image/Build/UBNT
-B $(4) -v $(5).$(6).OpenWrt.$(REVISION) \
-k $(KDIR)/vmlinux-$(2).bin.lzma \
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
- -o $(BIN_DIR)/openwrt-$(BOARD)-$(2)-$(1).bin
+ -o $(call imgname,$(1),$(2)).bin
endef
define Image/Build/Planex
@@ -174,6 +174,10 @@ define Image/Build/Template/Linksys8M/squashfs
$(call Image/Build/Template/Linksys8M,squashfs,$(1),$(2),$(3))
endef
+define Image/Build/Template/Linksys8M/jffs2-64k
+ $(call Image/Build/Template/Linksys8M,jffs2-64k,$(1),$(2),$(3))
+endef
+
define Image/Build/Template/AP81
$(call Image/Build/AP81,$(1),$(2),$(3),$(4))
endef
@@ -190,6 +194,10 @@ define Image/Build/Template/AP83/squashfs
$(call Image/Build/Template/AP83,squashfs,$(1),$(2))
endef
+define Image/Build/Template/AP83/jffs2-64k
+ $(call Image/Build/Template/AP83,jffs2-64k,$(1),$(2))
+endef
+
define Image/Build/Template/TPLINK
$(call Image/Build/TPLINK,$(1),$(2),$(3),$(4))
endef
@@ -206,6 +214,10 @@ define Image/Build/Template/UBNT/squashfs
$(call Image/Build/Template/UBNT,squashfs,$(1),$(2),$(3),$(4),$(5))
endef
+define Image/Build/Template/UBNT/jffs2-64k
+ $(call Image/Build/Template/UBNT,jffs2-64k,$(1),$(2),$(3),$(4),$(5))
+endef
+
define Image/Build/Template/Planex
$(call Image/Build/Planex,$(1),$(2),$(3))
endef
@@ -214,6 +226,10 @@ define Image/Build/Template/Planex/squashfs
$(call Image/Build/Template/Planex,squashfs,$(1),$(2))
endef
+define Image/Build/Template/Planex/jffs2-64k
+ $(call Image/Build/Template/Planex,jffs2-64k,$(1),$(2))
+endef
+
define Image/Build/Profile/AP83
$(call Image/Build/Template/AP83/$(1),ap83,board=AP83)
endef