summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-27 23:44:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-27 23:44:04 +0000
commit2c2bf90a8ed8b0ae12367888d9a43a7c192073cc (patch)
tree4dd091ed4f957e17b75d462c07e00b2c5bef9019
parentc1ab24d04a54c24677b21138e57f8bb16c588b0b (diff)
downloadmaster-31e0f0ae-2c2bf90a8ed8b0ae12367888d9a43a7c192073cc.tar.gz
master-31e0f0ae-2c2bf90a8ed8b0ae12367888d9a43a7c192073cc.tar.bz2
master-31e0f0ae-2c2bf90a8ed8b0ae12367888d9a43a7c192073cc.zip
fix ccache build (#1415)
SVN-Revision: 6412
-rw-r--r--toolchain/ccache/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/toolchain/ccache/Makefile b/toolchain/ccache/Makefile
index 348aed0fce..e8e85b442a 100644
--- a/toolchain/ccache/Makefile
+++ b/toolchain/ccache/Makefile
@@ -19,24 +19,31 @@ PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
-ifneq ($(shell which ccache),)
- define Build/Configure
- $(call Build/Configure/Default)
- endef
-
+ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
define Build/Compile
- $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
+ $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
endef
define Build/Install
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(STAGING_DIR)" \
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(STAGING_DIR)" \
install
endef
define Build/Clean
- $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+ -$(MAKE) -C $(PKG_BUILD_DIR) uninstall
-$(MAKE) -C $(PKG_BUILD_DIR) clean
+ $(call Build/Clean/Default)
+ endef
+else
+ define Build/Prepare
+ endef
+ define Build/Configure
+ endef
+ define Build/Compile
+ endef
+ define Build/Clean
endef
endif
+
$(eval $(call HostBuild))