summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph C. Lehner <joseph.c.lehner@gmail.com>2016-05-30 12:59:33 +0200
committerJohn Crispin <john@phrozen.org>2016-05-30 22:52:59 +0200
commit2a589539ba4b94229218ce5dac3bc2c40fef86d4 (patch)
tree5d07bc50dee089eea939e3e5601bed8117bafa8d
parent0fa01e25ed1aeac975433c0222b96dd2c05097ba (diff)
downloadmaster-31e0f0ae-2a589539ba4b94229218ce5dac3bc2c40fef86d4.tar.gz
master-31e0f0ae-2a589539ba4b94229218ce5dac3bc2c40fef86d4.tar.bz2
master-31e0f0ae-2a589539ba4b94229218ce5dac3bc2c40fef86d4.zip
ramips: fix Netgear EX2700 images
The previous image creation code would have failed if the unpadded kernel uImage size was less than 64 bytes from the next erase block boundary. Fix that. Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com>
-rw-r--r--target/linux/ramips/image/mt7620.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index d7acb1b8f9..d6da803b52 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -8,8 +8,9 @@ define Build/tplink-header
endef
define Build/pad-kernel-ex2700
- dd if=$@ of=$@.new bs=64k conv=sync && truncate -s -64 $@.new \
- && cat ex2700-fakeroot.uImage >> $@.new && mv $@.new $@
+ dd if=/dev/zero of=$@.pad bs=64 count=1 && cat $@ $@.pad \
+ | dd of=$@.new bs=64k conv=sync && truncate -s -64 $@.new \
+ && cat ex2700-fakeroot.uImage >> $@.new && rm $@.pad && mv $@.new $@
endef
define Build/netgear-header