summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-13 00:26:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-13 00:26:34 +0000
commit29b91ef01a0ad053119a3fd6d1d7b91dd7946de9 (patch)
tree6494f4f5fe38ce6f3fc737c7046edfb8ff86476b
parent8c3ea37f2f51d11563c93250846c00141af09ec3 (diff)
downloadmaster-31e0f0ae-29b91ef01a0ad053119a3fd6d1d7b91dd7946de9.tar.gz
master-31e0f0ae-29b91ef01a0ad053119a3fd6d1d7b91dd7946de9.tar.bz2
master-31e0f0ae-29b91ef01a0ad053119a3fd6d1d7b91dd7946de9.zip
introduce a menuconfig option to turn off static linking of host utilities
SVN-Revision: 33154
-rw-r--r--Config.in7
-rw-r--r--include/host-build.mk4
2 files changed, 10 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index 0553712f76..e865777bee 100644
--- a/Config.in
+++ b/Config.in
@@ -153,6 +153,13 @@ menu "Global build settings"
When this option is enabled, packages are built with the full versions of iconv and GNU gettext
instead of the default OpenWrt stubs. If uClibc is used, it is also built with locale support.
+ config BUILD_STATIC_TOOLS
+ default y
+ bool "Attempt to link host utilities statically"
+ help
+ Linking host utilities like sed or firmware-utils statically increases the portability of the
+ generated ImageBuilder and SDK tarballs, however it may fail on some Linux distributions.
+
config SHADOW_PASSWORDS
bool
prompt "Enable shadow password support"
diff --git a/include/host-build.mk b/include/host-build.mk
index a8bc79ea67..40af5c87cc 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -66,7 +66,9 @@ HOST_CONFIGURE_ARGS = \
HOST_CONFIGURE_CMD = ./configure
ifneq ($(HOST_OS),Darwin)
- HOST_STATIC_LINKING = -static
+ ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
+ HOST_STATIC_LINKING = -static
+ endif
endif
define Host/Configure/Default