summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-26 00:52:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-26 00:52:51 +0000
commit28c9621bef80d114ce681b1dfff66b8cec4b5581 (patch)
tree493b614073324e2262eb58133d95c2b4d9b93f41
parent4e60cfe51f97990eb1244e2813d12d514a761d7c (diff)
downloadmaster-31e0f0ae-28c9621bef80d114ce681b1dfff66b8cec4b5581.tar.gz
master-31e0f0ae-28c9621bef80d114ce681b1dfff66b8cec4b5581.tar.bz2
master-31e0f0ae-28c9621bef80d114ce681b1dfff66b8cec4b5581.zip
minor cleanup
SVN-Revision: 6381
-rw-r--r--package/alsa/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/package/alsa/Makefile b/package/alsa/Makefile
index 8aa80e74a5..347ef76276 100644
--- a/package/alsa/Makefile
+++ b/package/alsa/Makefile
@@ -46,21 +46,18 @@ ifeq ($(LINUX_KARCH),mips)
KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
endif
-define Build/Configure
- (cd $(PKG_BUILD_DIR); \
- CFLAGS="$(KERNEL_C_INCS)" \
- ./configure \
- --with-build="$(LINUX_DIR)" \
- --with-kernel="$(LINUX_DIR)" \
- --with-cross="$(KERNEL_CROSS)" \
- --with-redhat=no \
- --with-suse=no \
- --with-oss=yes \
- --with-isapnp=no \
- --with-sequencer=no \
- --with-cards=usb-audio \
- );
-endef
+CONFIGURE_VARS:= \
+ CFLAGS="$(KERNEL_C_INCS)"
+
+CONFIGURE_ARGS:= \
+ --with-build="$(LINUX_DIR)" \
+ --with-kernel="$(LINUX_DIR)" \
+ --with-redhat=no \
+ --with-suse=no \
+ --with-oss=yes \
+ --with-isapnp=no \
+ --with-sequencer=no \
+ --with-cards=usb-audio
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \