summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2009-01-29 23:52:35 +0000
committerLars-Peter Clausen <lars@metafoo.de>2009-01-29 23:52:35 +0000
commit24f02449ff8a681108a11f7995871d52aa790dff (patch)
tree6614ad57a707b85c34fe370f2adc4dc4e3f3796a
parentdb059cc0ff8aaece3baef42325d8701376447da6 (diff)
downloadmaster-31e0f0ae-24f02449ff8a681108a11f7995871d52aa790dff.tar.gz
master-31e0f0ae-24f02449ff8a681108a11f7995871d52aa790dff.tar.bz2
master-31e0f0ae-24f02449ff8a681108a11f7995871d52aa790dff.zip
Add menuconfig option for enabling profiling in the kernel.
SVN-Revision: 14272
-rw-r--r--Config.in6
-rw-r--r--include/kernel-defaults.mk1
2 files changed, 7 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index 0f131f0623..7c98044530 100644
--- a/Config.in
+++ b/Config.in
@@ -124,6 +124,12 @@ config KERNEL_KALLSYMS
default n
help
This will give you more information in stack traces from kernel oopses
+config KERNEL_PROFILING
+ bool "Compile the kernel with profiling enabled"
+ default n
+ help
+ Enable the extended profiling support mechanisms used by profilers such
+ as OProfile.
endmenu
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 4aa5c0ef18..e3897a64cc 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -87,6 +87,7 @@ endef
define Kernel/Configure/Default
$(LINUX_CONFCMD) > $(LINUX_DIR)/.config.target
echo "$(if $(CONFIG_KERNEL_KALLSYMS),CONFIG_KALLSYMS=y,# CONFIG_KALLSYMS is not set)" >> $(LINUX_DIR)/.config.target
+ echo "$(if $(CONFIG_KERNEL_PROFILING),CONFIG_PROFILING=y,# CONFIG_PROFILING is not set)" >> $(LINUX_DIR)/.config.target
echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
$(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config > $(LINUX_DIR)/.config.override