summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 19:19:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 19:19:24 +0000
commit239205d3357a6f2c13933f676cc601e9379a5e38 (patch)
tree8665e6e588b25fa5ff99a7e49f0f92027db98d47
parent097e1357e447f847ec912e6cb8ccc94a5179d4f0 (diff)
downloadmaster-31e0f0ae-239205d3357a6f2c13933f676cc601e9379a5e38.tar.gz
master-31e0f0ae-239205d3357a6f2c13933f676cc601e9379a5e38.tar.bz2
master-31e0f0ae-239205d3357a6f2c13933f676cc601e9379a5e38.zip
change OS to HOST_OS
SVN-Revision: 5030
-rw-r--r--openwrt/tools/mtd-utils/Makefile2
-rw-r--r--openwrt/tools/sstrip/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/tools/mtd-utils/Makefile b/openwrt/tools/mtd-utils/Makefile
index f67ccf758f..bc15f0a671 100644
--- a/openwrt/tools/mtd-utils/Makefile
+++ b/openwrt/tools/mtd-utils/Makefile
@@ -19,7 +19,7 @@ PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
include $(INCLUDE_DIR)/host-build.mk
CFLAGS := $(HOSTCFLAGS) -O2 -I../include
-ifneq ($(OS),Linux)
+ifneq ($(HOST_OS),Linux)
CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h -include endian.h
endif
diff --git a/openwrt/tools/sstrip/Makefile b/openwrt/tools/sstrip/Makefile
index dc3ff4f6da..4e409e0d8d 100644
--- a/openwrt/tools/sstrip/Makefile
+++ b/openwrt/tools/sstrip/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/host-build.mk
PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/sstrip
OS:=$(shell uname)
-ifeq ($(OS),Darwin)
+ifeq ($(HOST_OS),Darwin)
CFLAGS += -I./include
endif