summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-01-08 16:51:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-01-08 16:51:01 +0000
commit2273aadfb29b79bc0c52477ad10dfc69b84ca36d (patch)
treef5c37f4b13d50aafed8bb200062a5b6b1ffb255c
parentbe28e9d4385b70ca3648d71128a5a75a19b39324 (diff)
downloadmaster-31e0f0ae-2273aadfb29b79bc0c52477ad10dfc69b84ca36d.tar.gz
master-31e0f0ae-2273aadfb29b79bc0c52477ad10dfc69b84ca36d.tar.bz2
master-31e0f0ae-2273aadfb29b79bc0c52477ad10dfc69b84ca36d.zip
fix grub installation on target images, regression caused by multi-libc support
SVN-Revision: 13936
-rw-r--r--target/linux/x86/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 839646e547..a740b0b63c 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -49,9 +49,9 @@ ifneq ($(HOST_OS),Darwin)
define Image/Prepare/grub
# for the image builder
$(CP) \
- $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage1 \
- $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage2 \
- $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/e2fs_stage1_5 \
+ $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/stage1 \
+ $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/stage2 \
+ $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/e2fs_stage1_5 \
$(KDIR)/
endef
else