summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:27 +0000
commit21e09858f13eb471582ca09f1ce306a004203fb2 (patch)
treebfda449af920262834242f9df852ef1295568492
parent1b4c04cab22f81cc43fb22b6c57a02345b36515c (diff)
downloadmaster-31e0f0ae-21e09858f13eb471582ca09f1ce306a004203fb2.tar.gz
master-31e0f0ae-21e09858f13eb471582ca09f1ce306a004203fb2.tar.bz2
master-31e0f0ae-21e09858f13eb471582ca09f1ce306a004203fb2.zip
add missing fix for etrax compile without axis toolchain
SVN-Revision: 11413
-rw-r--r--target/linux/etrax/patches/100-compile_fixes.patch30
1 files changed, 20 insertions, 10 deletions
diff --git a/target/linux/etrax/patches/100-compile_fixes.patch b/target/linux/etrax/patches/100-compile_fixes.patch
index a33582ca00..6a976d8ff6 100644
--- a/target/linux/etrax/patches/100-compile_fixes.patch
+++ b/target/linux/etrax/patches/100-compile_fixes.patch
@@ -1,7 +1,7 @@
Index: linux-2.6.25.4/arch/cris/arch-v10/boot/Makefile
===================================================================
---- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/Makefile 2008-06-06 20:20:55.000000000 +0100
-+++ linux-2.6.25.4/arch/cris/arch-v10/boot/Makefile 2008-06-06 20:21:20.000000000 +0100
+--- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/Makefile 2008-06-09 17:00:36.381498250 +0200
++++ linux-2.6.25.4/arch/cris/arch-v10/boot/Makefile 2008-06-09 17:00:40.967491000 +0200
@@ -2,7 +2,6 @@
# arch/cris/arch-v10/boot/Makefile
#
@@ -20,8 +20,8 @@ Index: linux-2.6.25.4/arch/cris/arch-v10/boot/Makefile
@cp $< $@
Index: linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/Makefile
===================================================================
---- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/compressed/Makefile 2008-06-06 20:20:55.000000000 +0100
-+++ linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/Makefile 2008-06-06 20:56:01.000000000 +0100
+--- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/compressed/Makefile 2008-06-09 17:00:36.381498250 +0200
++++ linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/Makefile 2008-06-09 17:00:40.967491000 +0200
@@ -2,12 +2,10 @@
# arch/cris/arch-v10/boot/compressed/Makefile
#
@@ -51,8 +51,8 @@ Index: linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/Makefile
$(call if_changed,image)
Index: linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/misc.c
===================================================================
---- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/compressed/misc.c 2008-06-06 20:20:55.000000000 +0100
-+++ linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/misc.c 2008-06-06 21:02:10.000000000 +0100
+--- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/compressed/misc.c 2008-06-09 17:00:36.381498250 +0200
++++ linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/misc.c 2008-06-09 17:00:40.967491000 +0200
@@ -5,7 +5,7 @@
* adapted for Linux.
*
@@ -119,8 +119,8 @@ Index: linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/misc.c
}
Index: linux-2.6.25.4/arch/cris/arch-v10/mm/init.c
===================================================================
---- linux-2.6.25.4.orig/arch/cris/arch-v10/mm/init.c 2008-06-06 20:20:55.000000000 +0100
-+++ linux-2.6.25.4/arch/cris/arch-v10/mm/init.c 2008-06-06 20:21:20.000000000 +0100
+--- linux-2.6.25.4.orig/arch/cris/arch-v10/mm/init.c 2008-06-09 17:00:36.385496500 +0200
++++ linux-2.6.25.4/arch/cris/arch-v10/mm/init.c 2008-06-09 17:00:40.967491000 +0200
@@ -184,6 +184,9 @@
free_area_init_node(0, &contig_page_data, zones_size, PAGE_OFFSET >> PAGE_SHIFT, 0);
@@ -133,8 +133,8 @@ Index: linux-2.6.25.4/arch/cris/arch-v10/mm/init.c
* is called before any driver is initialized.
Index: linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/head.S
===================================================================
---- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/compressed/head.S 2008-06-06 20:20:55.000000000 +0100
-+++ linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/head.S 2008-06-06 21:03:05.000000000 +0100
+--- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/compressed/head.S 2008-06-09 17:00:36.385496500 +0200
++++ linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/head.S 2008-06-09 17:00:40.971489250 +0200
@@ -10,13 +10,14 @@
#define ASSEMBLER_MACROS_ONLY
@@ -289,3 +289,13 @@ Index: linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/head.S
+cmd_line_addr:
.dword 0
#include "../../lib/hw_settings.S"
+Index: linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/decompress.ld
+===================================================================
+--- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/compressed/decompress.ld 2008-05-15 17:00:12.000000000 +0200
++++ linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/decompress.ld 2008-06-09 17:12:54.930425750 +0200
+@@ -1,4 +1,4 @@
+-OUTPUT_FORMAT(elf32-us-cris)
++OUTPUT_FORMAT(elf32-cris)
+
+ MEMORY
+ {